summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSébastien Leduc2021-06-30 19:36:39 +0200
committerSébastien Leduc2021-06-30 19:36:39 +0200
commit614a71dbbfa9ee0b46a6ef43e5b7e80c482bc05b (patch)
treed4420c90c6f8523e24f36aa451089cc8315d2f5a
parent2af7e92380521a536b375d28c1ffc8dae96d3afc (diff)
downloadaur-python2-paver.tar.gz
Update to 1.3.4
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee46ca83fe94..0574de3a4668 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = python2-paver
pkgdesc = Build, Distribute and Deploy Python Projects
- pkgver = 1.2.4
+ pkgver = 1.3.4
pkgrel = 1
- url = http://www.blueskyonmars.com/projects/paver/
- arch = i686
- arch = x86_64
+ url = https://github.com/paver/paver
+ arch = any
license = BSD
depends = python2
- source = http://pypi.python.org/packages/source/P/Paver/Paver-1.2.4.tar.gz
- md5sums = dbb94faf8b004eb9920b632808c20560
+ source = python2-paver-1.3.4.tar.gz::https://github.com/paver/paver/archive/Paver-1.3.4.tar.gz
+ md5sums = df1eae12c15f81c436232846378b2784
pkgname = python2-paver
diff --git a/PKGBUILD b/PKGBUILD
index 328f6df8bf4d..faaef9b8c76a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,25 @@
# Contributor: ponsfoot <cabezon dot hashimoto at gmail dot com>
pkgname=python2-paver
-pkgver=1.2.4
+pkgver=1.3.4
pkgrel=1
pkgdesc="Build, Distribute and Deploy Python Projects"
-arch=('i686' 'x86_64')
-url="http://www.blueskyonmars.com/projects/paver/"
+arch=('any')
+url="https://github.com/paver/paver"
license=('BSD')
depends=('python2')
-source=("http://pypi.python.org/packages/source/P/Paver/Paver-${pkgver}.tar.gz")
-md5sums=('dbb94faf8b004eb9920b632808c20560')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/paver/paver/archive/Paver-$pkgver.tar.gz")
+md5sums=('df1eae12c15f81c436232846378b2784')
-package() {
- cd "${srcdir}/Paver-${pkgver}"
- python2 setup.py install --prefix="${pkgdir}/usr"
- install -D "${srcdir}/Paver-${pkgver}/LICENSE.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+build() {
+ cd paver-Paver-$pkgver
+ python setup.py build
+}
+package() {
+ cd paver-Paver-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
# fix python3 conflict
for _f in "$pkgdir"/usr/bin/*; do
mv -v "$_f" "${_f}2"