summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenri Chain2017-05-27 02:59:45 +0200
committerHenri Chain2017-05-27 03:01:50 +0200
commit8b57f8a39f7cb23f00a40ef7c39c6fd909cb5e9e (patch)
tree13a9fe0d829ae0f6a20272794d842e414a8b06aa
downloadaur-python2-pbd.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7ed51fa9ca6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat May 27 01:00:40 UTC 2017
+pkgbase = python2-pbd
+ pkgdesc = Protocol Buffers Disassembler
+ pkgver = 0.9.r5.g5af39c7
+ pkgrel = 1
+ url = https://github.com/unusual-thoughts/pbd
+ arch = any
+ license = MIT
+ depends = python
+ depends = python2-protobuf
+ source = python2-pbd::git+https://github.com/unusual-thoughts/pbd.git
+ md5sums = SKIP
+
+pkgname = python2-pbd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..640a8821ffda
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Henri Chain <henri@henri-chain.com>
+_pkgname=pbd
+pkgname=python2-${_pkgname}
+pkgver=0.9.r5.g5af39c7
+pkgrel=1
+pkgdesc='Protocol Buffers Disassembler'
+arch=('any')
+url="https://github.com/unusual-thoughts/${_pkgname}"
+depends=('python' 'python2-protobuf')
+license=('MIT')
+source=("${pkgname}::git+https://github.com/unusual-thoughts/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/"
+ python2 setup.py install --root="$pkgdir"
+}
+