summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilo Mirate2015-06-08 11:24:25 -0400
committerMilo Mirate2015-06-08 11:24:25 -0400
commitdfd7a0ea8b593c3fe407aabddf1cfb5378fc86a9 (patch)
tree0ec4afada6bdef02051ae48421f64e482968352e
downloadaur-dfd7a0ea8b593c3fe407aabddf1cfb5378fc86a9.tar.gz
Initial import
-rw-r--r--.AURINFO15
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
3 files changed, 57 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..2b19e75809b4
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-plumbum
+ pkgdesc = Shell combinators library.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/plumbum
+ install =
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-six
+ source = http://pypi.python.org/packages/source/p/plumbum/plumbum-1.4.2.tar.gz
+ options = !emptydirs
+
+pkgname = python2-plumbum
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f9ccb50f3244
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-plumbum
+ pkgdesc = Shell combinators library.
+ pkgver = 1.4.2
+ pkgrel = 1
+ url = http://pypi.python.org/pypi/plumbum
+ arch = any
+ license = GPL
+ depends = python2
+ depends = python2-six
+ options = !emptydirs
+ source = http://pypi.python.org/packages/source/p/plumbum/plumbum-1.4.2.tar.gz
+ md5sums = 38b526af9012a5282ae91dfe372cefd3
+
+pkgname = python2-plumbum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1207b6829d9a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Milo Mirate <mmirate@gmx.com>
+_pkgname=plumbum
+pkgname=python2-plumbum
+pkgver=1.4.2
+pkgrel=1
+pkgdesc="Shell combinators library."
+arch=('any')
+url="http://pypi.python.org/pypi/plumbum"
+license=('GPL')
+groups=()
+depends=('python2' 'python2-six')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("http://pypi.python.org/packages/source/p/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+md5sums=('38b526af9012a5282ae91dfe372cefd3')
+
+package() {
+ cd "$srcdir/${_pkgname}-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: