summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLingMan2025-02-15 11:57:57 +0100
committerLingMan2025-02-15 12:01:45 +0100
commitd976b844c21253228796edcf5ca9fff395d6642d (patch)
treef74ac2a609cc03bd425c4dd5edffe4b3e41c24e9
parente5cb3e5bcd030661836231bf6d4086e782ce4054 (diff)
downloadaur-python2-pyasn1.tar.gz
Revert "update PKGBUILD"
This reverts commit 470bb33384b2e4ba76a670f12fdc9302335ecb75. It contained no useful changes, only made the script harder to read. No bump to the pkgrel, since the change is purely non-functional and a rebuild shouldn't be triggered.
-rw-r--r--PKGBUILD29
1 files changed, 11 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54f298eef5ad..77a417443a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,27 @@
# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Eric Bélanger <eric@archlinux.org>
-# Contributor: Pellegrino Prevete (tallero) <pellegrinoprevete@gmail.com>
-_py="python2"
-_pkg="pyasn1"
-pkgname="${_py}-${_pkg}"
+pkgname='python2-pyasn1'
+_name="${pkgname#python2-}"
pkgver=0.4.8
pkgrel=5
pkgdesc='Pure-Python implementation of ASN.1 types and DER/BER/CER codecs (X.208)'
arch=('any')
-url="https://pypi.org/project/${_pkg}/${pkgver}/"
+url="https://pypi.org/project/${_name}/${pkgver}/"
license=('BSD')
-depends=("${_py}")
-makedepends=("${_py}-setuptools")
-_tarname="${_pkg}-${pkgver}"
-_pypi_url="https://pypi.python.org/packages/source"
-source=(
- "${_pypi_url}/${_pkg::1}/${_pkg}/${_tarname}.tar.gz")
-b2sums=(
- '5c00b47c2014e599d1aa2e14c3004b3688786c7afd160c85709d5a0f324166abb1d29ebbd9f3e13100166e7176710e4dc6e1b8fcf80db5f5bdaa202912f8a023'
-)
+depends=('python2')
+makedepends=('python2-setuptools')
+_tarname="${_name}-${pkgver}"
+source=("https://pypi.python.org/packages/source/${_name::1}/${_name}/${_tarname}.tar.gz")
+b2sums=('5c00b47c2014e599d1aa2e14c3004b3688786c7afd160c85709d5a0f324166abb1d29ebbd9f3e13100166e7176710e4dc6e1b8fcf80db5f5bdaa202912f8a023')
check() {
cd "${_tarname}"
- "${_py}" setup.py test
+ python2 setup.py test
}
package() {
cd "${_tarname}"
- "${_py}" setup.py install --root="${pkgdir}"
- install -Dm 644 LICENSE.rst \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python2 setup.py install --root="${pkgdir}"
+ install -Dm 644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}