summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaesim4042017-08-28 11:13:32 +0300
committerCaesim4042017-08-28 11:13:32 +0300
commit8b3fa1d8a1df9403759026cdc96b0759f41eb381 (patch)
treec8e91f34d45359084175963077469a8277d6a016
parent81123505e290772c39d3005dbfa7f73d558e7aa2 (diff)
downloadaur-python2-pyjsparser.tar.gz
2.5.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 350009b98e64..5761cdbbb989 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python2-pyjsparser
pkgdesc = Fast JavaScript parser (based on esprima.js)
- pkgver = 2.4.5
+ pkgver = 2.5.2
pkgrel = 1
url = https://github.com/PiotrDabkowski/pyjsparser
arch = any
license = MIT
makedepends = python2-setuptools
depends = python2
- source = https://files.pythonhosted.org/packages/source/p/pyjsparser/pyjsparser-2.4.5.tar.gz
- source = https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md
- md5sums = 69a028f632baf7fe79fe2df253cbfd26
- md5sums = faa744092d3fb3314632e815e7c3a560
+ source = https://files.pythonhosted.org/packages/source/p/pyjsparser/pyjsparser-2.5.2.tar.gz
+ source = https://raw.githubusercontent.com/PiotrDabkowski/pyjsparser/master/LICENSE
+ sha256sums = e4a659df3db42a2ff9fbc961eb6d4076a0b945e1aadfc20d48f913ad5dca011d
+ sha256sums = ee43880fad97e97a3d77333915c22766926f1e3dcd0c3e29b112e42246fef4f1
pkgname = python2-pyjsparser
diff --git a/PKGBUILD b/PKGBUILD
index 9b53d1b220d9..d44b57a8facf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python2-pyjsparser
_pypiname=${pkgname/python2-/}
-pkgver=2.4.5
+pkgver=2.5.2
pkgrel=1
pkgdesc="Fast JavaScript parser (based on esprima.js)"
arch=(any)
@@ -11,15 +11,14 @@ license=(MIT)
depends=(python2)
makedepends=(python2-setuptools)
source=("https://files.pythonhosted.org/packages/source/${_pypiname::1}/${_pypiname}/${_pypiname}-${pkgver}.tar.gz"
- "https://raw.githubusercontent.com/PiotrDabkowski/Js2Py/master/LICENSE.md")
-md5sums=("69a028f632baf7fe79fe2df253cbfd26"
- "faa744092d3fb3314632e815e7c3a560")
-
+ "https://raw.githubusercontent.com/PiotrDabkowski/pyjsparser/master/LICENSE")
+sha256sums=('e4a659df3db42a2ff9fbc961eb6d4076a0b945e1aadfc20d48f913ad5dca011d'
+ 'ee43880fad97e97a3d77333915c22766926f1e3dcd0c3e29b112e42246fef4f1')
package() {
cd "${srcdir}"
- install -Dm644 LICENSE.md "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
cd "${_pypiname}-${pkgver}"