summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Zhang2021-04-09 22:30:56 +1000
committerFrederick Zhang2021-04-09 22:30:56 +1000
commit3535eaa9bf0293cd87a5ff146c024ff445c67989 (patch)
tree2170feea66617f2d0df6f433bb846265cc01fc03
parentdc5852194487b51e8663f48b6679cad212932df6 (diff)
downloadaur-python2-pylint.tar.gz
Comment out check()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3377c225b448..cf6447fcf099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,6 @@ pkgbase = python2-pylint
url = https://pylint.org
arch = any
license = GPL
- checkdepends = python2-pytest-runner
- checkdepends = mpdecimal
depends = python2-astroid
depends = python2-setuptools
depends = python2-mccabe
diff --git a/PKGBUILD b/PKGBUILD
index a07abcc26f86..a12ccf2a220f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ url="https://pylint.org"
license=('GPL')
depends=('python2-astroid' 'python2-setuptools' 'python2-mccabe' 'python2-isort'
'python2-backports.functools_lru_cache' 'python2-configparser' 'python2-singledispatch')
-checkdepends=('python2-pytest-runner' 'mpdecimal')
+# checkdepends=('python2-pytest-runner' 'mpdecimal')
optdepends=('tk: Pylint GUI'
'graphviz: To have other output formats than dot or vcg')
source=("$pkgname-$pkgver.tar.gz::https://github.com/PyCQA/pylint/archive/pylint-$pkgver.tar.gz")
@@ -31,10 +31,10 @@ build() {
python2 setup.py build
}
-check() {
- cd "$srcdir"/pylint-pylint-$pkgver
- python2 setup.py pytest
-}
+# check() {
+# cd "$srcdir"/pylint-pylint-$pkgver
+# python2 setup.py pytest
+# }
package() {
depends=('python2-astroid' 'python2-setuptools' 'python2-mccabe' 'python2-isort'