summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Forencich2015-07-20 12:26:00 -0700
committerAlex Forencich2015-07-20 12:26:00 -0700
commit1cf7ab69f3c55af83f22a3f74a854682cf9e2d9a (patch)
tree397c9c665a7d9e4d82bddcdf69a543d06e48acde
downloadaur-python2-pyvisa-py-git.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc525966a6b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-pyvisa-py-git
+ pkgdesc = A pure python backend for PyVISA
+ pkgver = 0.1.r64.gef0fc09
+ pkgrel = 1
+ url = https://github.com/hgrecco/pyvisa-py
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python2-distribute
+ makedepends = python2-docutils
+ depends = python2
+ depends = python2-pyvisa
+ provides = python2-pyvisa-py
+ source = pyvisa-py::git+https://github.com/hgrecco/pyvisa-py.git
+ md5sums = SKIP
+
+pkgname = python2-pyvisa-py-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..893956e3bbbc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alex Forencich <alex@alexforencich.com>
+pkgname=python2-pyvisa-py-git
+pkgver=0.1.r64.gef0fc09
+pkgrel=1
+pkgdesc="A pure python backend for PyVISA"
+arch=('any')
+url="https://github.com/hgrecco/pyvisa-py"
+license=('MIT')
+depends=('python2' 'python2-pyvisa')
+makedepends=('git' 'python2-distribute' 'python2-docutils')
+provides=('python2-pyvisa-py')
+
+_gitroot='https://github.com/hgrecco/pyvisa-py.git'
+_gitname='pyvisa-py'
+
+source=("$_gitname::git+$_gitroot")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --tags --long | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python2 setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+}
+