summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdwin Peters2018-04-24 14:08:31 +1000
committerEdwin Peters2018-04-24 14:08:31 +1000
commit4acf0adb3cacc23d7efd581bd1ade29b9feedb71 (patch)
tree754ed15ccf4f3bed7ab61fb8221f029fab3da604
downloadaur-python2-reedsolomon-git.tar.gz
initial submission
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5e59678792f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python2-reedsolomon-git
+ pkgdesc = Pure-Python Reed Solomon encoder/decoder
+ pkgver = c9ec28a
+ pkgrel = 1
+ url = https://github.com/tomerfiliba/reedsolomon
+ arch = any
+ license = BSD
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = python2
+ optdepends = cython2
+ source = git+https://github.com/tomerfiliba/reedsolomon.git
+ sha256sums = SKIP
+
+pkgname = python2-reedsolomon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..def57ede6784
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Edwin Peters <slimed13 at hotmail dot com>
+
+pkgname=python2-reedsolomon-git
+pkgver=c9ec28a
+pkgrel=1
+pkgdesc="Pure-Python Reed Solomon encoder/decoder"
+arch=('any')
+url="https://github.com/tomerfiliba/reedsolomon"
+license=('BSD')
+depends=('python2' )
+optdepends=('cython2' )
+makedepends=('python2-setuptools' 'git')
+source=(git+https://github.com/tomerfiliba/reedsolomon.git)
+sha256sums=(SKIP)
+
+package() {
+ cd ${srcdir}/reedsolomon
+
+ # ignores any LDFLAGS set in makepkg.conf
+ unset LDFLAGS
+
+ python2 ./setup.py install --root=${pkgdir}
+
+} \ No newline at end of file