summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2019-02-15 14:49:40 +0100
committerCedric Girard2019-02-15 14:49:40 +0100
commit2b28048a439cf363d33baa1d5a3900499cc1fadb (patch)
tree159df1f5ece6e9d4865652a1d93530b43d733d2d
parentda1fbb7342aad3638053aafac9cd451cd59bd4bd (diff)
downloadaur-python2-requests-git.tar.gz
upgpkg: python2-requests-git v2.21.0.16.gc9309e4c-1
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD11
-rw-r--r--certs.patch23
3 files changed, 25 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98f46490e84f..10d7164eda34 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,31 @@
-# Generated by mksrcinfo v8
-# Fri Dec 4 15:25:14 UTC 2015
pkgbase = python2-requests-git
pkgdesc = Python HTTP for Humans.
- pkgver = v2.8.1.59.g40ce366
+ pkgver = v2.21.0.16.gc9309e4c
pkgrel = 1
url = http://python-requests.org
arch = any
license = custom: ISC
makedepends = git
makedepends = python2-distribute
+ makedepends = python2-chardet
+ makedepends = python2-idna
+ makedepends = python2-urllib3
+ makedepends = python2-certifi
+ makedepends = python2-pyopenssl
+ makedepends = python2-cryptography
depends = python2
+ depends = python2-chardet
+ depends = python2-idna
+ depends = python2-urllib3
+ depends = python2-certifi
depends = python2-pyopenssl
- depends = python2-ndg-httpsclient
- depends = python2-pyasn1
- optdepends = python2-certifi: SSL support
- optdepends = python2-grequests: asynchronous requests with gevent
- optdepends = python2-simplejson
+ depends = python2-cryptography
provides = python2-requests
conflicts = python2-requests
source = requests::git+https://github.com/kennethreitz/requests.git
source = certs.patch
sha256sums = SKIP
- sha256sums = db84c6224f77bbf55c49bd69db71a98b3798f1d3275d7079861e1fbade8cc03f
+ sha256sums = 7e4d8c39b47c338630583d88d9da9c1a91891e6339f61ad5567f3cffe5128d24
pkgname = python2-requests-git
diff --git a/PKGBUILD b/PKGBUILD
index 357626ffd361..9a125eeb3364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,14 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
pkgname=python2-requests-git
-pkgver=v2.8.1.59.g40ce366
+pkgver=v2.21.0.16.gc9309e4c
pkgrel=1
_libname=${pkgname/python2-/}
pkgdesc="Python HTTP for Humans."
url="http://python-requests.org"
conflicts=('python2-requests')
-makedepends=('git' 'python2-distribute')
-optdepends=('python2-certifi: SSL support'
- 'python2-grequests: asynchronous requests with gevent'
- 'python2-simplejson')
-depends=('python2' 'python2-pyopenssl' 'python2-ndg-httpsclient' 'python2-pyasn1')
+makedepends=('git' 'python2-distribute' 'python2-chardet' 'python2-idna' 'python2-urllib3' 'python2-certifi' 'python2-pyopenssl' 'python2-cryptography')
+depends=('python2' 'python2-chardet' 'python2-idna' 'python2-urllib3' 'python2-certifi' 'python2-pyopenssl' 'python2-cryptography')
provides=('python2-requests')
license=('custom: ISC')
arch=('any')
@@ -20,7 +17,7 @@ source=('requests::git+https://github.com/kennethreitz/requests.git'
certs.patch
)
sha256sums=('SKIP'
- 'db84c6224f77bbf55c49bd69db71a98b3798f1d3275d7079861e1fbade8cc03f')
+ '7e4d8c39b47c338630583d88d9da9c1a91891e6339f61ad5567f3cffe5128d24')
pkgver() {
cd "$srcdir"/requests
diff --git a/certs.patch b/certs.patch
index 69d27be85abf..06094c422aa7 100644
--- a/certs.patch
+++ b/certs.patch
@@ -1,19 +1,12 @@
---- requests/certs.py.orig 2015-12-04 16:16:33.773055294 +0100
-+++ requests/certs.py 2015-12-04 16:20:30.106729891 +0100
-@@ -11,7 +11,6 @@
- environment, you can change the definition of where() to return a separately
- packaged CA bundle.
+diff -Naur requests.orig/certs.py requests/certs.py
+--- requests.orig/certs.py 2019-02-15 13:43:26.819151260 +0100
++++ requests/certs.py 2019-02-15 13:45:10.316052919 +0100
+@@ -14,5 +14,8 @@
"""
--import os.path
-
- try:
- from certifi import where
-@@ -19,7 +18,7 @@
- def where():
- """Return the preferred certificate bundle."""
- # vendored bundle inside Requests
-- return os.path.join(os.path.dirname(__file__), 'cacert.pem')
-+ return "/etc/ssl/certs/ca-certificates.crt"
+ from certifi import where
++def where():
++ return "/etc/ssl/certs/ca-certificates.crt"
++
if __name__ == '__main__':
print(where())