summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Monfils2019-04-16 10:45:26 +0200
committerNathan Monfils2019-04-16 10:47:12 +0200
commit7970d1bae9a8fb15e872ccfbcf7e5938b37d8bb4 (patch)
tree4e00510ce1dccde1e1d972ebfb70797b0541748e
downloadaur-python2-revdb-hg.tar.gz
Created package
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dae0b38acf00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python2-revdb-hg
+ pkgdesc = RevDB, the Reverse Debugger
+ pkgver = r48.f34e846835e3
+ pkgrel = 1
+ url = https://bitbucket.org/pypy/revdb
+ arch = any
+ license = UNKNOWN
+ makedepends = python2-setuptools
+ makedepends = mercurial
+ depends = pypy2-revdb
+ provides = python2-revdb
+ conflicts = python2-revdb
+ source = python2-revdb-hg::hg+https://bitbucket.org/pypy/revdb
+ md5sums = SKIP
+
+pkgname = python2-revdb-hg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..038cdc17e0cf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+*.tar.xz
+python2-revdb-hg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c048f302bf75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nathan Monfils <nathan.monfils@hotmail.fr>
+
+pkgname=python2-revdb-hg
+pkgver=r48.f34e846835e3
+pkgrel=1
+pkgdesc="RevDB, the Reverse Debugger"
+arch=(any)
+url="https://bitbucket.org/pypy/revdb"
+license=('UNKNOWN')
+depends=('pypy2-revdb')
+makedepends=(python2-setuptools mercurial)
+provides=("${pkgname%-hg}")
+conflicts=("${pkgname%-hg}")
+source=("${pkgname}::hg+https://bitbucket.org/pypy/revdb")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}"
+ python2 setup.py install --skip-build -O1 --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python*/site-packages/tests
+}
+