summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLorenz Steinert2019-12-01 19:08:18 +0100
committerLorenz Steinert2019-12-01 19:08:18 +0100
commit6aa8a88734aee06c0f4723c34231183aa6f4f0da (patch)
treec0de649ea291d5774052c88cba6181565825567d
downloadaur-python2-robot-detection.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a5b5e0d10f2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python2-robot-detection
+ pkgdesc = Library for detecting if a HTTP User Agent header is likely to be a bot
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/robot-detection
+ arch = any
+ license = GPL
+ makedepends = python2-setuptools
+ options = !emptydirs
+ source = https://github.com/rory/robot-detection/archive/v0.4.0.tar.gz
+ sha256sums = 9fa0423a890fd5856e5494076ba6e67abd2f4173d91c8b292819dfaa815b5060
+
+pkgname = python2-robot-detection
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..692ecea7b047
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python2-robot-detection')
+_pkgbase='robot-detection'
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Library for detecting if a HTTP User Agent header is likely to be a bot"
+arch=(any)
+url="https://pypi.python.org/pypi/robot-detection"
+license=('GPL')
+options=(!emptydirs)
+source=("https://github.com/rory/robot-detection/archive/v${pkgver}.tar.gz")
+sha256sums=('9fa0423a890fd5856e5494076ba6e67abd2f4173d91c8b292819dfaa815b5060')
+makedepends=('python2-setuptools')
+
+package_python2-robot-detection() {
+ depends=('python2')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: