summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-06-18 01:40:35 -0300
committerDanilo J. S. Bellini2022-06-18 01:40:35 -0300
commit9581865687b88699537c245fffed9a0de805f568 (patch)
tree06fcff9e91e2a00147f666a948d51e87a7cf1ad7
parenta560ffe66b535da8bcf042d7297c47d43adb8fb4 (diff)
downloadaur-python2-scandir.tar.gz
Add build/lib.linux-* to PYTHONPATH (v1.10.0-8)
This ensures the shared object can be accessed while running the tests
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3aff4362482..0b52a908e7a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python2-scandir
pkgdesc = Better directory iterator and faster os.walk() alternative
pkgver = 1.10.0
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/benhoyt/scandir
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 4a3b97eff630..75a39f972365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=python2-scandir
_name=${pkgname#python2-}
pkgver=1.10.0
-pkgrel=7
+pkgrel=8
pkgdesc='Better directory iterator and faster os.walk() alternative'
arch=('x86_64')
url='https://github.com/benhoyt/scandir'
@@ -23,7 +23,8 @@ check() {
cd "$srcdir/$_name-$pkgver"
touch test/__init__.py
rm -rf test/testdir
- LC_ALL=C.UTF-8 python2 -m unittest discover -v
+ LC_ALL=C.UTF-8 PYTHONPATH="$PWD/build/lib.linux-$CARCH-2.7" \
+ python2 -m unittest discover -v
}
package() {