summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-10 18:58:49 +0200
committerMarcell Meszaros2022-07-10 18:58:49 +0200
commit5654a1ca432bd68d4fef0023772450334aa6f3c3 (patch)
tree276415b659b4ff1bc20af66193669a6fd6cad194
parent7f135e6c9ddc8a321bee48ffc4fb69b29482e1f8 (diff)
downloadaur-python2-sip.tar.gz
4.19.25-1: update
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD39
3 files changed, 48 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca33a612d9c3..fc92ff0f576a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = python2-sip
- pkgver = 4.19.24
+ pkgdesc = Legacy Python 2 bindings for C and C++ libraries
+ pkgver = 4.19.25
pkgrel = 1
- url = https://www.riverbankcomputing.com/software/sip/intro
+ url = https://riverbankcomputing.com/software/sip/download
arch = x86_64
- license = custom:"sip"
- makedepends = python2
- source = https://www.riverbankcomputing.com/static/Downloads/sip/4.19.24/sip-4.19.24.tar.gz
- sha256sums = edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5
+ license = custom
+ license = GPL2
+ license = GPL3
+ depends = glibc
+ depends = python2
+ source = https://www.riverbankcomputing.com/static/Downloads/sip/4.19.25/sip-4.19.25.tar.gz
+ b2sums = f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98
pkgname = python2-sip
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6696e5c62eee
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
diff --git a/PKGBUILD b/PKGBUILD
index 4b0bb2527d09..a6121224f79a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,33 @@
-# Maintainer: Jose Riha <jose1711 gmail com>
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
+# Contributor: Jose Riha <jose1711 gmail com>
pkgname=python2-sip
-pkgver=4.19.24
+_name="${pkgname#python2-}"
+pkgver=4.19.25
pkgrel=1
+pkgdesc='Legacy Python 2 bindings for C and C++ libraries'
arch=('x86_64')
-url='https://www.riverbankcomputing.com/software/sip/intro'
-license=('custom:"sip"')
-makedepends=('python2')
-source=("https://www.riverbankcomputing.com/static/Downloads/sip/$pkgver/sip-$pkgver.tar.gz")
-sha256sums=('edcd3790bb01938191eef0f6117de0bf56d1136626c0ddb678f3a558d62e41e5')
-
-prepare() {
- mkdir -p build-py2
-}
+url="https://riverbankcomputing.com/software/${_name}/download"
+license=('custom' 'GPL2' 'GPL3')
+depends=(
+ 'glibc'
+ 'python2'
+)
+_tarname="${_name}-${pkgver}"
+source=("https://www.riverbankcomputing.com/static/Downloads/${_name}/${pkgver}/${_tarname}.tar.gz")
+b2sums=('f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98')
build() {
- cd "$srcdir"/build-py2
- python2 ../sip-$pkgver/configure.py CFLAGS="$CFLAGS" LFLAGS="$LDFLAGS"
+ cd "${_tarname}"
+ python2 configure.py \
+ CFLAGS="${CFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ --no-tools
make
}
package() {
- cd build-py2
- make DESTDIR="$pkgdir" install
- install -Dm644 ../sip-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- rm -r "$pkgdir"/usr/{bin,include} # conflicts with sip
+ cd "${_tarname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 'LICENSE' -t "${pkgdir}/usr/share/licenses/${pkgname}"
}