summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Nagie2016-06-01 16:03:57 +0200
committerMike Nagie2016-06-01 16:03:57 +0200
commit15b3181b7c754cd3df45f4c998200342ba02f2ff (patch)
tree7e2593b2d4d9fed4252b6b18d6010d3eef99cc56
downloadaur-15b3181b7c754cd3df45f4c998200342ba02f2ff.tar.gz
initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD33
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d27b4928f074
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python2-sipsimple
+ pkgdesc = Python SDK for development of SIP end-points
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://download.ag-projects.com/SipClient
+ arch = i686
+ arch = x86_64
+ license = custom:MIT
+ license = LGPL
+ makedepends = cython2
+ makedepends = subversion
+ depends = alsa-lib
+ depends = util-linux
+ depends = python2-dateutil
+ depends = python2-dnspython
+ depends = python2-eventlib
+ depends = python2-msrplib
+ depends = python2-xcaplib
+ depends = python-otr
+ depends = python2-application
+ options = !makeflags
+ source = http://download.ag-projects.com/SipClient/python-sipsimple-3.0.0.tar.gz
+ md5sums = e14cbb693ecef8fd5f719f8bb5df99be
+
+pkgname = python2-sipsimple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e04293d379b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mike Nagie <echo 'cHJvbWlrZTE5ODdAZ21haWwuY29tCg==' | base64 -d>
+# Maintainer: Ingo Gottwald <in dot gottwald at gmail dot com>
+# Contributor : speps <speps at aur dot archlinux dot org>
+# Contributor: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=python2-sipsimple
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Python SDK for development of SIP end-points"
+license=('custom:MIT' 'LGPL')
+arch=('i686' 'x86_64')
+url="http://download.ag-projects.com/SipClient"
+depends=('alsa-lib' 'util-linux' 'python2-dateutil'
+ 'python2-dnspython' 'python2-eventlib' 'python2-msrplib' 'python2-xcaplib' 'python-otr' 'python2-application')
+makedepends=('cython2' 'subversion')
+options=('!makeflags')
+source=("http://download.ag-projects.com/SipClient/python-sipsimple-$pkgver.tar.gz")
+md5sums=('e14cbb693ecef8fd5f719f8bb5df99be')
+
+build() {
+ cd "$srcdir/python-sipsimple-$pkgver"
+ python2 setup.py build_ext --pjsip-clean-compile
+}
+
+package() {
+ cd "$srcdir/python-sipsimple-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+
+ # license
+ install -Dm644 LICENSE \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+