summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2020-08-02 10:51:01 +0200
committerJose Riha2020-08-02 10:51:01 +0200
commit79fc671c84762a8e5109f3ef63b653d859691405 (patch)
tree7def548752a4df27b78f92774ede5196fd99ba65
parentd47341c1b2caf3dfeff03c7c81778f3fe52451f0 (diff)
downloadaur-79fc671c84762a8e5109f3ef63b653d859691405.tar.gz
Update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--pj_attr_gcc10.patch12
-rw-r--r--snd_pcm_drop.patch12
4 files changed, 23 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee3e89f4a31e..7c3005163b8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python2-sipsimple
pkgdesc = Python SDK for development of SIP end-points
- pkgver = 3.4.2
+ pkgver = 3.5.0
pkgrel = 1
url = http://download.ag-projects.com/SipClient
arch = x86_64
@@ -19,10 +19,10 @@ pkgbase = python2-sipsimple
depends = python2-otr
depends = ffmpeg
options = !makeflags
- source = https://github.com/AGProjects/python-sipsimple/archive/release-3.4.2.tar.gz
- source = snd_pcm_drop.patch
- sha512sums = 007205bf5a88b2ebfa32541e3a3dc47effa1854648371d8fcc90b07a302fffe5bde4c2f8e2231fdf24df397bc237d7bd1e6414f17fc4d9b6486137bcb98fccc7
- sha512sums = 887cb3cfee82280c07bf4ba1779aebc2fbc49e2afff87ed3cd1e58b5ac8973e6d7f93e86284511dfef154a1f991bc985b4c97fc3b7d327d6791b72a124526683
+ source = https://github.com/AGProjects/python-sipsimple/archive/release-3.5.0.tar.gz
+ source = pj_attr_gcc10.patch
+ sha512sums = 80ccededddb9a7eae229cb032bfd4e6a37ecf402a1ceded9fa592695f92fa458d2635a4484f2ef350e76fcb37736f0660535286b3f9535681e73c8791e3745cb
+ sha512sums = 60703259bb829f7b13cb3645f4cbaf6dd5662cada2c0f2f3765cfc74456f8e60c5001793aed59d71fd12c3d2abcbf12be3b4260e5ad6c061abdf3df8c9de0740
pkgname = python2-sipsimple
diff --git a/PKGBUILD b/PKGBUILD
index 75bb1ec2b774..55762819791f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgname=python-sipsimple
pkgname=python2-sipsimple
-pkgver=3.4.2
+pkgver=3.5.0
pkgrel=1
pkgdesc="Python SDK for development of SIP end-points"
license=('custom:MIT' 'LGPL')
@@ -19,13 +19,13 @@ depends=('alsa-lib' 'util-linux' 'python2-dateutil' 'cython2' 'python2-cjson' 'o
'python2-dnspython' 'python2-eventlib' 'python2-msrplib' 'python2-xcaplib' 'python2-otr' 'ffmpeg')
options=('!makeflags')
source=("https://github.com/AGProjects/${_pkgname}/archive/release-${pkgver}.tar.gz"
- "snd_pcm_drop.patch")
-sha512sums=('007205bf5a88b2ebfa32541e3a3dc47effa1854648371d8fcc90b07a302fffe5bde4c2f8e2231fdf24df397bc237d7bd1e6414f17fc4d9b6486137bcb98fccc7'
- '887cb3cfee82280c07bf4ba1779aebc2fbc49e2afff87ed3cd1e58b5ac8973e6d7f93e86284511dfef154a1f991bc985b4c97fc3b7d327d6791b72a124526683')
+ "pj_attr_gcc10.patch")
+sha512sums=('80ccededddb9a7eae229cb032bfd4e6a37ecf402a1ceded9fa592695f92fa458d2635a4484f2ef350e76fcb37736f0660535286b3f9535681e73c8791e3745cb'
+ '60703259bb829f7b13cb3645f4cbaf6dd5662cada2c0f2f3765cfc74456f8e60c5001793aed59d71fd12c3d2abcbf12be3b4260e5ad6c061abdf3df8c9de0740')
prepare() {
- cd "${srcdir}/${_pkgname}-release-${pkgver}"
- patch -p1 < "${srcdir}"/snd_pcm_drop.patch
+ cd "${srcdir}"
+ patch -p1 -i "${srcdir}"/pj_attr_gcc10.patch
}
build() {
diff --git a/pj_attr_gcc10.patch b/pj_attr_gcc10.patch
new file mode 100644
index 000000000000..91f61d6c5f32
--- /dev/null
+++ b/pj_attr_gcc10.patch
@@ -0,0 +1,12 @@
+diff -aur src/python-sipsimple-release-3.5.0/deps/pjsip/pjlib/include/pj/list.h src.orig/python-sipsimple-release-3.5.0/deps/pjsip/pjlib/include/pj/list.h
+--- src/python-sipsimple-release-3.5.0/deps/pjsip/pjlib/include/pj/list.h 2020-02-14 12:06:07.000000000 +0100
++++ src.orig/python-sipsimple-release-3.5.0/deps/pjsip/pjlib/include/pj/list.h 2020-08-02 10:40:15.118079182 +0200
+@@ -71,7 +71,7 @@
+ * must initialize the 'value' member to an appropriate value (typically the
+ * owner itself).
+ */
+-struct pj_list
++extern struct pj_list
+ {
+ PJ_DECL_LIST_MEMBER(void);
+ } PJ_ATTR_MAY_ALIAS; /* may_alias avoids warning with gcc-4.4 -Wall -O2 */
diff --git a/snd_pcm_drop.patch b/snd_pcm_drop.patch
deleted file mode 100644
index 9cef2f389f81..000000000000
--- a/snd_pcm_drop.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Nurp python-sipsimple-release-3.4.2.orig/deps/pjsip/pjmedia/src/pjmedia-audiodev/alsa_dev.c python-sipsimple-release-3.4.2/deps/pjsip/pjmedia/src/pjmedia-audiodev/alsa_dev.c
---- python-sipsimple-release-3.4.2.orig/deps/pjsip/pjmedia/src/pjmedia-audiodev/alsa_dev.c 2019-03-26 11:12:31.000000000 +0100
-+++ python-sipsimple-release-3.4.2/deps/pjsip/pjmedia/src/pjmedia-audiodev/alsa_dev.c 2019-06-17 23:05:50.915679360 +0200
-@@ -616,7 +616,7 @@ static int ca_thread_func (void *arg)
-
- tstamp.u64 += nframes;
- }
-- snd_pcm_drain (pcm);
-+ snd_pcm_drop (pcm);
- TRACE_((THIS_FILE, "ca_thread_func: Stopped"));
-
- return PJ_SUCCESS;