summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-10-06 14:26:47 +0200
committerPellegrino Prevete2021-10-06 14:26:47 +0200
commit4843760f27d632c9c1a54af5564b6d4542f14f48 (patch)
treee2522cb231bee5e88b35b8123bff84411ee6d7f7
downloadaur-python2-sphinxcontrib-applehelp.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..519dfeeb2edc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-sphinxcontrib-applehelp
+ pkgdesc = Sphinx extension which outputs Apple help books
+ pkgver = 1.0.2
+ pkgrel = 6
+ url = https://github.com/sphinx-doc/sphinxcontrib-applehelp
+ arch = any
+ license = BSD
+ checkdepends = python2-pytest
+ checkdepends = python2-sphinx
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-applehelp/sphinxcontrib-applehelp-1.0.2.tar.gz
+ sha256sums = a072735ec80e7675e3f432fcae8610ecf509c5f1869d17e2eecff44389cdbc58
+
+pkgname = python2-sphinxcontrib-applehelp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2e1ee5800b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Daniel M. Capella <polyzen@archlinux.org>
+
+_name=sphinxcontrib-applehelp
+pkgname=python2-$_name
+pkgver=1.0.2
+pkgrel=6
+pkgdesc='Sphinx extension which outputs Apple help books'
+arch=('any')
+url=https://github.com/sphinx-doc/sphinxcontrib-applehelp
+license=('BSD')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest' 'python2-sphinx')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a072735ec80e7675e3f432fcae8610ecf509c5f1869d17e2eecff44389cdbc58')
+
+build() {
+ cd $_name-$pkgver
+ python2 setup.py build
+}
+
+# check() {
+# cd $_name-$pkgver
+# pytest2 --disable-pytest-warnings
+# }
+
+package() {
+ cd $_name-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: