summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-10-06 14:36:45 +0200
committerPellegrino Prevete2021-10-06 14:36:45 +0200
commit6de2327347502412e801ad596a83448fa99d81d6 (patch)
tree346fdb0a62fa0604fd36df1cf97cc4161edf0665
downloadaur-python2-sphinxcontrib-qthelp.tar.gz
cominciando ad aggiungere Info, aggiunti copyright notices
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bab1edac4dc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python2-sphinxcontrib-qthelp
+ pkgdesc = Sphinx extension which outputs QtHelp document
+ pkgver = 1.0.3
+ pkgrel = 6
+ url = https://github.com/sphinx-doc/sphinxcontrib-qthelp
+ arch = any
+ license = BSD
+ checkdepends = python2-pytest
+ checkdepends = python2-sphinx
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/source/s/sphinxcontrib-qthelp/sphinxcontrib-qthelp-1.0.3.tar.gz
+ sha256sums = 4c33767ee058b70dba89a6fc5c1892c0d57a54be67ddd3e7875a18d14cba5a72
+
+pkgname = python2-sphinxcontrib-qthelp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df44f9c11a4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Pellegrino Prevete <pellegrinoprevete@gmail.com>
+# Contributor: Daniel M. Capella <polyzen@archlinux.org>
+
+_name=sphinxcontrib-qthelp
+pkgname=python2-sphinxcontrib-qthelp
+pkgver=1.0.3
+pkgrel=6
+pkgdesc='Sphinx extension which outputs QtHelp document'
+arch=('any')
+url=https://github.com/sphinx-doc/sphinxcontrib-qthelp
+license=('BSD')
+makedepends=('python2-setuptools')
+checkdepends=('python2-pytest' 'python2-sphinx')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('4c33767ee058b70dba89a6fc5c1892c0d57a54be67ddd3e7875a18d14cba5a72')
+
+build() {
+ cd $_name-$pkgver
+ python2 setup.py build
+}
+
+# check() {
+# cd $_name-$pkgver
+# pytest2
+# }
+
+package() {
+ cd $_name-$pkgver
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir"/usr/share/licenses/$pkgname LICENSE
+}
+
+# vim:set ts=2 sw=2 et: