summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2013-10-19 09:13:16 +0400
committerAleksey Filippov2013-10-19 09:13:16 +0400
commit50b9bde9cbc42c6f5093e406b73e71ebb7b3e7ec (patch)
treeff1551049652161bae3dea126074055351b93502
downloadaur-python2-ttystatus-git.tar.gz
obnam package update.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..00c5f9466d47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python2-ttystatus-git
+ pkgdesc = progress and status updates on terminals for Python
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = http://liw.fi/ttystatus/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = python2
+ provides = python2-ttystatus
+ conflicts = python2-ttystatus
+ replaces = python2-ttystatus-bzr
+ source = python2-ttystatus-git::git://git.liw.fi/ttystatus
+ md5sums = SKIP
+
+pkgname = python2-ttystatus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04d042b7a6dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+pkgname=python2-ttystatus-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="progress and status updates on terminals for Python"
+arch=('i686' 'x86_64')
+url="http://liw.fi/ttystatus/"
+license=('GPL3')
+groups=()
+depends=('python2')
+makedepends=('git')
+provides=('python2-ttystatus')
+conflicts=('python2-ttystatus')
+replaces=('python2-ttystatus-bzr')
+backup=()
+options=()
+install=
+source=("$pkgname::git://git.liw.fi/ttystatus")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ find . -type f -exec sed -ri "s|^#!/usr/bin/python$|&2|g" '{}' '+'
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: