summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2022-06-12 05:07:40 -0300
committerDanilo J. S. Bellini2022-06-12 05:07:40 -0300
commita94a62013d9202e7067dd1f61daee67a777a885f (patch)
tree2f8062f6a0461ebd317f49415679fd34d9356d48
downloadaur-python2-wcwidth.tar.gz
Add v0.2.5-6
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95621feab371
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python2-wcwidth
+ pkgdesc = Library to measure the width of unicode strings in a terminal
+ pkgver = 0.2.5
+ pkgrel = 6
+ url = https://github.com/jquast/wcwidth
+ arch = any
+ license = MIT
+ makedepends = python2-setuptools
+ depends = python2-backports.functools_lru_cache
+ source = python2-wcwidth-0.2.5.tar.gz::https://github.com/jquast/wcwidth/archive/refs/tags/0.2.5.tar.gz
+ sha256sums = b08fa4c7d7be1ba86950c2d746eb0d19de80842ab7457df5b3fcd3bf52e02b08
+
+pkgname = python2-wcwidth
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ff6f7fa4740f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+pkgname=python2-wcwidth
+_name=${pkgname#python2-}
+pkgver=0.2.5
+pkgrel=6
+pkgdesc='Library to measure the width of unicode strings in a terminal'
+url='https://github.com/jquast/wcwidth'
+license=('MIT')
+arch=('any')
+depends=('python2-backports.functools_lru_cache')
+makedepends=('python2-setuptools')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('b08fa4c7d7be1ba86950c2d746eb0d19de80842ab7457df5b3fcd3bf52e02b08')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.txt"
+}