summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-02-27 22:45:19 +1100
committerMatthew Gamble2017-02-27 22:45:19 +1100
commit81619ee0d3e6094915ce9ea2773c8d054894046c (patch)
treedd14fb157b7d9237828a275d468f37065ffad443
parent888af6867d9b218d0f92f5c33f182972a60efd71 (diff)
downloadaur-pywb.tar.gz
Update to latest version
-rw-r--r--.SRCINFO39
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 43 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34c66020c162..408cfe620cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,32 @@
# Generated by mksrcinfo v8
-# Sat Aug 20 02:08:26 UTC 2016
+# Mon Feb 27 11:44:37 UTC 2017
pkgbase = pywb
pkgdesc = Python WayBack for web archive replay and url-rewriting HTTP/S web proxy
- pkgver = 0.31.0
- pkgrel = 2
+ pkgver = 0.33.1
+ pkgrel = 1
url = https://pypi.python.org/pypi/pywb
arch = any
license = GPL
- makedepends = python2-setuptools
- depends = python2
- depends = python2-six
- depends = python2-chardet
- depends = python2-requests
- depends = python2-redis
- depends = python2-jinja
- depends = python2-surt>=0.3.0
- depends = python2-brotli
+ checkdepends = python-pytest
+ checkdepends = python-pytest-cov
+ checkdepends = python-fakeredis
+ checkdepends = python-webtest
+ checkdepends = python-mock
+ makedepends = python-setuptools
+ depends = python
+ depends = python-six
+ depends = python-chardet
+ depends = python-requests
+ depends = python-redis
+ depends = python-jinja
+ depends = python-surt
+ depends = python-brotlipy
depends = brotli
- depends = python2-yaml
- depends = python2-watchdog
- depends = python2-webencodings
- source = https://pypi.python.org/packages/01/99/7a658eb65745b3ed29f358bd01b1d99f4b741764ee0590bd4b6fd427d06e/pywb-0.31.0.tar.gz
- md5sums = 0db827af3dfbaeacf76fa03e842a9693
+ depends = python-yaml
+ depends = python-watchdog
+ depends = python-webencodings
+ source = https://pypi.python.org/packages/5f/cb/3e5cf97c970a069778488a7556de6510fb0d923db9bf45489d536c28170c/pywb-0.33.1.tar.gz
+ md5sums = 4d233d0099b8a85f9b7c68a101c9bde3
pkgname = pywb
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..24f2ec57e666
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.pkg.tar.xz
+/*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 7dac65e2ac41..913835fe0cbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,35 @@
# Maintainer: Matthew Gamble <git@matthewgamble.net>
-
-# The tests aren't working on my machine at the moment, not sure why.
+# Contributor: evotopid
pkgname=pywb
-pkgver=0.31.0
-pkgrel=2
+pkgver=0.33.1
+pkgrel=1
pkgdesc="Python WayBack for web archive replay and url-rewriting HTTP/S web proxy"
-arch=('any')
+arch=("any")
url="https://pypi.python.org/pypi/pywb"
-license=('GPL')
-depends=('python2' 'python2-six' 'python2-chardet' 'python2-requests' 'python2-redis' 'python2-jinja' 'python2-surt>=0.3.0' 'python2-brotli' 'brotli' 'python2-yaml' 'python2-watchdog' 'python2-webencodings')
-makedepends=('python2-setuptools')
-#checkdepends=('python2-pytest' 'python2-pytest-cov' 'python2-webtest' 'python2-mock')
-source=("https://pypi.python.org/packages/01/99/7a658eb65745b3ed29f358bd01b1d99f4b741764ee0590bd4b6fd427d06e/pywb-${pkgver}.tar.gz")
-md5sums=('0db827af3dfbaeacf76fa03e842a9693')
+license=("GPL")
+depends=("python" "python-six" "python-chardet" "python-requests" "python-redis" "python-jinja" "python-surt" "python-brotlipy" "brotli" "python-yaml" "python-watchdog" "python-webencodings")
+makedepends=("python-setuptools")
+checkdepends=("python-pytest" "python-pytest-cov" "python-fakeredis" "python-webtest" "python-mock")
+source=("https://pypi.python.org/packages/5f/cb/3e5cf97c970a069778488a7556de6510fb0d923db9bf45489d536c28170c/pywb-${pkgver}.tar.gz")
+md5sums=("4d233d0099b8a85f9b7c68a101c9bde3")
build() {
cd "${srcdir}/pywb-${pkgver}"
- python2 setup.py build
+ python setup.py build
}
+# More than half the tests are failing on my machine at the moment, not sure why.
#check() {
# cd "${srcdir}/pywb-${pkgver}"
-# python2 setup.py test
+# python setup.py test
#}
package() {
cd "${srcdir}/pywb-${pkgver}"
- python2 setup.py install --root=${pkgdir} --skip-build
- # Something performs automatic validation of the contents of this file, and thinks that brotlipy isn't installed.
- # In actual fact it is, just not with that package name. As far as I can tell, pywb runs just fine regardless.
- sed -i 's/^brotlipy/#brotlipy/' "${pkgdir}/usr/lib/python2.7/site-packages/pywb-${pkgver}-py2.7.egg-info/requires.txt"
- # Remove unnecessary empty folders
- rm -r "${pkgdir}/usr/sample_archive"
+ python setup.py install --root="${pkgdir}" --skip-build --optimize=1
+ # TODO: Consider removing sample files
+ #rm -r "${pkgdir}/usr/sample_archive"
# Remove non-namespaced tests that aren't necessary for the functioning of the package
- rm -r "${pkgdir}/usr/lib/python2.7/site-packages/tests"
+ rm -r "${pkgdir}/usr/lib/python3.6/site-packages/tests"
}