summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHector Mtz-Seara2018-09-24 19:19:49 +0200
committerHector Mtz-Seara2018-09-24 19:19:49 +0200
commitcce2b498c2cbbfb3ffa24386c7d9d52cc820a347 (patch)
tree107bffc0e2a0c9bd294ef4c7ea0d1ee2b038a7cf
parentc907a603e3330c44c2e5fd753ad9a0cbeb3d8391 (diff)
downloadaur-pyzo.tar.gz
Improved PKGBUILD thanks to Victor Mikael
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 9 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 473c9920288c..527a94f84933 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = pyzo
pkgdesc = Pyzo is a cross-platform Python IDE focused on interactivity and introspection, which makes it very suitable for scientific computing.
pkgver = 4.6.0
- pkgrel = 1
+ pkgrel = 2
url = http://pyzo.org
arch = any
license = BSD
makedepends = python-setuptools
- optdepends = python-pyqt4: At least one qt4 python bindings should be installed
- optdepends = python-pyside: At lease one qt4 python bindings should be installed
+ depends = python-pyqt5
source = https://github.com/pyzo/pyzo/archive/v4.6.0.tar.gz
sha1sums = a1d600a54256ca983fed9a4214b42c250285e1ab
diff --git a/PKGBUILD b/PKGBUILD
index 6b9729212d5a..73ca11c2f994 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,15 @@
#Contributor: Hector Mtz-Seara <hseara.#at#.gmail*.*com>
pkgname=pyzo
pkgver=4.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="Pyzo is a cross-platform Python IDE focused on interactivity and introspection, which makes it very suitable for scientific computing."
url="http://pyzo.org"
license=("BSD")
arch=('any')
-#depends=('python-pyzolib')
-#replaces=('iep')
-#conflicts=('iep')
-optdepends=(
- 'python-pyqt4: At least one qt4 python bindings should be installed'
- 'python-pyside: At lease one qt4 python bindings should be installed'
-)
+depends=('python-pyqt5') # At lease one qt5 python bindings should be installed
+#depends=('pyside2') # At lease one qt5 python bindings should be installed
makedepends=('python-setuptools')
+pyver=3.7 #To be adjusted to the default python version in the system
source=("https://github.com/pyzo/pyzo/archive/v${pkgver}.tar.gz")
@@ -39,10 +35,10 @@ package(){
Version=${pkgver}
Type=Application
Encoding=UTF-8
-Name=pyzo
-Comment=Pyzo is a cross-platform Python IDE
+Name=Pyzo
+GenericName=Pyzo is a cross-platform Python IDE
Exec=/usr/bin/pyzo
-Icon=/usr/lib/python3.6/site-packages/pyzo/resources/appicons/pyzologo.ico
+Icon=/usr/lib/python${pyver}/site-packages/pyzo/resources/appicons/pyzologo.ico
Categories=Python;Development;IDE;
EOF