summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2016-01-12 22:33:46 -0500
committerEli Schwartz2016-01-12 22:33:46 -0500
commit8557eb127e8fc7d78176da6cda245c2e76fa8ec0 (patch)
tree30f9c2034b43ef312d82b5ad2cb1ba7294dc9ee8
parent3a7ae88074c7f176aca6414fc11909e48adbdc21 (diff)
downloadaur-8557eb127e8fc7d78176da6cda245c2e76fa8ec0.tar.gz
upgpkg: qbittorrent-git 3.3.1.r141.049e622-1
- I decided I have no idea what the v3_3_x branch is for -- revert to the old (kludgy) pkgver method - No need to conflict/provide qbittorrent-qt(4|5), as long as everything conflicts/provides qbittorrent
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2235f3d6a7a..2753473efe2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qbittorrent-git
pkgdesc = A bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)
- pkgver = 3.3.1.r0.gd753988
+ pkgver = 3.3.1.r141.049e622
pkgrel = 1
url = http://www.qbittorrent.org/
install = qbittorrent.install
@@ -14,14 +14,11 @@ pkgbase = qbittorrent-git
depends = libtorrent-rasterbar
depends = qt5-base
depends = desktop-file-utils
- depends = hicolor-icon-theme
depends = xdg-utils
optdepends = python: needed for torrent search tab
provides = qbittorrent
- provides = qbittorrent-qt5
conflicts = qbittorrent
- conflicts = qbittorrent-qt4
- source = qbittorrent::git+https://github.com/qbittorrent/qBittorrent.git#branch=v3_3_x
+ source = qbittorrent::git+https://github.com/qbittorrent/qBittorrent.git
md5sums = SKIP
pkgname = qbittorrent-git
diff --git a/PKGBUILD b/PKGBUILD
index 1b3963064240..8c2b588a6fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,30 @@
# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Contributor: Eschwartz <eschwartz93@gmail.com>
+# Maintainer: Eschwartz <eschwartz93@gmail.com>
# Contributors: Ner0, Sevenseven
pkgname=qbittorrent-git
-pkgver=3.3.1.r0.gd753988
+pkgver=3.3.1.r141.049e622
pkgrel=1
pkgdesc="A bittorrent client powered by C++, Qt5 and the good libtorrent library (development version)"
arch=('i686' 'x86_64')
url="http://www.qbittorrent.org/"
license=('custom' 'GPL')
-depends=('libtorrent-rasterbar' 'qt5-base' 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils')
+depends=('libtorrent-rasterbar' 'qt5-base' 'desktop-file-utils' 'xdg-utils')
makedepends=('boost' 'git' 'qt5-tools')
optdepends=('python: needed for torrent search tab')
-conflicts=('qbittorrent' 'qbittorrent-qt4')
-provides=('qbittorrent' 'qbittorrent-qt5')
+conflicts=('qbittorrent')
+provides=('qbittorrent')
install=qbittorrent.install
-source=(${pkgname%-*}::"git+https://github.com/qbittorrent/qBittorrent.git#branch=v3_3_x")
+source=("${pkgname%-*}::git+https://github.com/qbittorrent/qBittorrent.git")
md5sums=('SKIP')
pkgver() {
cd ${pkgname%-*}
- git describe --long --tags | sed 's/^release-//;s/-/.r/;s/-/./'
+ _tag=$(git tag -l | sort -r | head -n1 | tr -cd 0-9.)
+ _rev=$(git rev-list --count release-${_tag}..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.%s" "$_tag" "$_rev" "$_hash"
}
build() {