summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2020-08-17 16:22:28 +0200
committerFabioLolix2020-08-17 16:22:28 +0200
commit876ac0bbed491f1d8f3e6d3778966e16dc6a5ddc (patch)
tree4205c16dea44a4e8d1502197162dee1ee62fa8cd
parente4fa83e61f4983524bbb68f73494139577de7140 (diff)
downloadaur-qcomicbook.tar.gz
revision
-rwxr-xr-x[-rw-r--r--].SRCINFO6
-rwxr-xr-x[-rw-r--r--]PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e85680b36b12..cabefe5a19a2 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = qcomicbook
pkgdesc = A reader of comic book archives
pkgver = 0.9.1
pkgrel = 1
- url = http://qcomicbook.org/
+ url = https://github.com/stolowski/QComicBook
arch = i686
arch = x86_64
license = GPL2
@@ -14,8 +14,8 @@ pkgbase = qcomicbook
optdepends = unace
optdepends = unrar
optdepends = rar
- source = https://github.com/stolowski/QComicBook/archive/0.9.1.tar.gz
- md5sums = d8762ff0698652cd2c383dbaa30cc132
+ source = qcomicbook-0.9.1.tar.gz::https://github.com/stolowski/QComicBook/archive/0.9.1.tar.gz
+ sha256sums = 39bb6ba0e20569985c930b0e8bdb19ae9c5453f27e9f7c01c6d44f56fb204619
pkgname = qcomicbook
diff --git a/PKGBUILD b/PKGBUILD
index b9c8c3b4db3d..060f22173869 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Fabio Loli <loli_fabio@protonmail.com>
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
# Contributor: kagan <juanynie AT gmail DOT com>
# Contributor: Valheru <valheru AT facticius DOT net>
# Contributor: jackoneill
@@ -7,18 +7,17 @@ pkgname=qcomicbook
pkgver=0.9.1
pkgrel=1
pkgdesc="A reader of comic book archives"
-url="http://qcomicbook.org/"
-arch=('i686' 'x86_64')
-license=('GPL2')
-depends=('qt5-x11extras'
- 'poppler-qt5')
+url="https://github.com/stolowski/QComicBook"
+arch=(i686 x86_64)
+license=(GPL2)
+depends=(qt5-x11extras poppler-qt5)
optdepends=('p7zip'
'unace'
'unrar'
'rar')
-makedepends=('cmake' 'qt5-tools')
-source=("https://github.com/stolowski/QComicBook/archive/$pkgver.tar.gz")
-md5sums=('d8762ff0698652cd2c383dbaa30cc132')
+makedepends=(cmake qt5-tools)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stolowski/QComicBook/archive/$pkgver.tar.gz")
+sha256sums=('39bb6ba0e20569985c930b0e8bdb19ae9c5453f27e9f7c01c6d44f56fb204619')
build() {
cd "$srcdir/QComicBook-$pkgver"