summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing-Wei Lan2013-10-06 00:23:51 +0800
committerTing-Wei Lan2013-10-06 00:23:51 +0800
commitf8c54aa24d294128209e873320989974a1b2529c (patch)
tree28e9efbf0c76ea339587690280d39d9a2c55c14c
downloadaur-f8c54aa24d294128209e873320989974a1b2529c.tar.gz
qelly-git: 1.0a (initial commit)
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41b78b45611c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = qelly-git
+ pkgdesc = Qelly is a Qt port of Nally
+ pkgver = 1.0a.9.g2d54801
+ pkgrel = 1
+ url = https://github.com/uranusjr/Qelly
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = qt4
+ depends = libqxt
+ provides = qelly
+ conflicts = qelly
+ source = qelly-git::git+https://github.com/uranusjr/Qelly.git
+ md5sums = SKIP
+
+pkgname = qelly-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8dd91612b605
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: lantw44 (at) gmail (dot) com
+
+pkgname=qelly-git
+pkgver=1.0a.9.g2d54801
+pkgrel=1
+pkgdesc="Qelly is a Qt port of Nally"
+arch=('x86_64' 'i686')
+url="https://github.com/uranusjr/Qelly"
+license=('GPL')
+depends=('qt4' 'libqxt')
+makedepends=()
+conflicts=('qelly')
+provides=('qelly')
+source=("$pkgname::git+https://github.com/uranusjr/Qelly.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ local ver="$(git describe --long)"
+ ver="${ver#v}"
+ ver="${ver//-/.}"
+ printf "%s" "$ver"
+}
+
+build() {
+ cd "$pkgname"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+ install -m 755 "bin/Qelly" "$pkgdir/usr/bin"
+}