summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDoug Newgard2018-03-23 11:56:03 -0500
committerDoug Newgard2018-03-23 11:56:03 -0500
commitfcbc7d9ac0292179381c9b0a4d7112a0046def35 (patch)
treefdab896435ac36bf0a4a9e66611f9573f580fa6b
parent1dd586edaf9eb7030231be25934e0264395198ea (diff)
downloadaur-qgis.tar.gz
Upstream update to 3.0.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3903f35e2ee7..aa2efdee993b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://qgis.org/
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = qgis
makedepends = txt2tags
makedepends = qt5-tools
makedepends = python-six
- makedepends = python-future
depends = expat
depends = gcc-libs
depends = gdal
@@ -47,8 +46,9 @@ pkgbase = qgis
optdepends = python-pygments: MetaSearch plugin; DB Manager plugin
optdepends = python-numpy: Processing plugin
optdepends = python-yaml: Processing plugin
- source = https://qgis.org/downloads/qgis-3.0.0.tar.bz2
- md5sums = ff6e7ad62e98ef32af41db42640f345d
+ optdepends = saga-gis-ltr: Saga processing tools
+ source = https://qgis.org/downloads/qgis-3.0.1.tar.bz2
+ md5sums = a9fac346ab7a4dfdf8755c7d3aecc3a0
pkgname = qgis
diff --git a/PKGBUILD b/PKGBUILD
index c2a35e12d612..87ef13503bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
# You will also need to install osgearth or fcgi, respectively, before building.
pkgname=qgis
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
url='https://qgis.org/'
@@ -22,7 +22,7 @@ depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'libzip' 'post
'qca-qt5' 'qextserialport' 'qscintilla-qt5' 'qt5-3d' 'qt5-base' 'qt5-location' 'qt5-svg'
'qt5-webkit' 'qtkeychain' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
'python' 'python-qscintilla-qt5' 'python-pyqt5' 'python-sip')
-makedepends=('cmake' 'gsl' 'perl' 'txt2tags' 'qt5-tools' 'python-six' 'python-future')
+makedepends=('cmake' 'gsl' 'perl' 'txt2tags' 'qt5-tools' 'python-six')
optdepends=('gpsbabel: GPS Tool plugin'
'gsl: Georeferencer plugin'
'python-gdal: DB Manager plugin; Processing plugin'
@@ -31,9 +31,10 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python-psycopg2: DB Manager plugin; Processing plugin'
'python-pygments: MetaSearch plugin; DB Manager plugin'
'python-numpy: Processing plugin'
- 'python-yaml: Processing plugin')
+ 'python-yaml: Processing plugin'
+ 'saga-gis-ltr: Saga processing tools')
source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('ff6e7ad62e98ef32af41db42640f345d')
+md5sums=('a9fac346ab7a4dfdf8755c7d3aecc3a0')
prepare() {
cd $pkgname-$pkgver
@@ -86,16 +87,12 @@ package() {
cd "$srcdir/$pkgname-$pkgver"
- # install desktop file and icons
+ # install desktop file and icon
install -Dm644 debian/qgis.desktop -t "$pkgdir/usr/share/applications/"
install -Dm644 images/icons/qgis_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/qgis.svg"
- for _res in 16x16 60x60 512x512; do
- install -Dm644 images/icons/qgis-icon-$_res.png "$pkgdir/usr/share/icons/hicolor/$_res/apps/qgis.png"
- done
# install mime information and icons
install -Dm644 debian/qgis.xml -t "$pkgdir/usr/share/mime/packages/"
- install -Dm644 images/icons/qgis-mime-icon.png "$pkgdir/usr/share/icons/hicolor/64x64/mimetypes/qgis-mime.png"
for _type in asc ddf dem dt0 dxf gml img mime mldata qgs qlr qml qpt shp sqlite; do
install -Dm644 images/icons/qgis_${_type}_icon.svg "$pkgdir/usr/share/icons/hicolor/scalable/mimetypes/qgis-$_type.svg"
done