summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Czernia2018-11-29 13:44:04 +0100
committerNils Czernia2018-11-29 13:44:04 +0100
commitb4dc9712c5111295bf3cd87af7581cfb537bf38c (patch)
treead6cdd4cac604c8742589a0aca185016dd0d14b3
parent6515d90b1d05ab0fcaccd67a0664ff34e8e49d5d (diff)
downloadaur-b4dc9712c5111295bf3cd87af7581cfb537bf38c.tar.gz
Updated to 4.12.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 13821b5536c6..bda85e021e42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qlcplus
pkgdesc = Q Light Controller Plus - The open DMX lighting desk software for controlling professional lighting fixtures.
- pkgver = 4.11.2
+ pkgver = 4.12.0
pkgrel = 1
url = http://qlcplus.org/
install = qlcplus.install
@@ -16,8 +16,8 @@ pkgbase = qlcplus
optdepends = ola: Open Lighting Architecture plugin
conflicts = qlc
conflicts = qlc-svn
- source = http://www.qlcplus.org/downloads/4.11.2/qlcplus_4.11.2.tar.gz
- md5sums = 461d8e77c344e73c183c5b17c4107135
+ source = https://github.com/mcallegari/qlcplus/archive/QLC+_4.12.0.tar.gz
+ sha256sums = b53488e2b3f395e63c88c7132593aaeca7ccba3a2007460c4739dee4f5aa0816
pkgname = qlcplus
diff --git a/PKGBUILD b/PKGBUILD
index d4035b2449a3..716449b96b6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jerome Lebleu <jerome dot lebleu at mailoo dot org>
pkgname=qlcplus
-pkgver=4.11.2
+pkgver=4.12.0
pkgrel=1
pkgdesc="Q Light Controller Plus - The open DMX lighting desk software for controlling professional lighting fixtures."
arch=('i686' 'x86_64')
@@ -12,16 +12,16 @@ depends=('qt4' 'libftdi-compat' 'libsndfile' 'libmad' 'shared-mime-info' 'fftw')
optdepends=('ola: Open Lighting Architecture plugin')
conflicts=('qlc' 'qlc-svn')
install=${pkgname}.install
-source=("http://www.qlcplus.org/downloads/${pkgver}/qlcplus_${pkgver}.tar.gz")
-md5sums=('461d8e77c344e73c183c5b17c4107135')
+source=("https://github.com/mcallegari/qlcplus/archive/QLC+_${pkgver}.tar.gz")
+sha256sums=('b53488e2b3f395e63c88c7132593aaeca7ccba3a2007460c4739dee4f5aa0816')
build() {
- cd "${srcdir}/qlcplus-${pkgver}"
+ cd "${srcdir}/qlcplus-QLC-_${pkgver}"
qmake-qt4 QMAKE_CXXFLAGS+=-Wno-error=unused-variable
make
}
package() {
- cd "${srcdir}/qlcplus-${pkgver}"
+ cd "${srcdir}/qlcplus-QLC-_${pkgver}"
make INSTALL_ROOT="${pkgdir}/" install
}