summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgit user2024-05-19 13:00:50 +0200
committergit user2024-05-19 13:00:50 +0200
commit684a1893cd460176800b4a96d4e6202ef295274b (patch)
tree816f51bb3078fac391548b544b87745851e4059b
parent4052607b1687b965c0eff2ca2d6199edcb2682dc (diff)
downloadaur-qmp3gain-git.tar.gz
* Switched to use `make install`,
* silenced compiler warnings.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD24
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6e5aa281361..74896024b68b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qmp3gain-git
pkgdesc = User interface front end supporting famous MP3Gain engine which analyzes and losslessly adjusts MP3 files to a specified target volume.
pkgver = 0.9.3.r123.20220727.95b2608
- pkgrel = 1
+ pkgrel = 2
url = https://sourceforge.net/projects/qmp3gain/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b3e69dd8eba3..6a6c5156864c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgname=qmp3gain
pkgname="${_pkgname}-git"
_gitname="${_pkgname}"
pkgver=0.9.3.r123.20220727.95b2608
-pkgrel=1
+pkgrel=2
pkgdesc='User interface front end supporting famous MP3Gain engine which analyzes and losslessly adjusts MP3 files to a specified target volume.'
url='https://sourceforge.net/projects/qmp3gain/ '
_giturl="git://git.code.sf.net/p/${_pkgname}/code"
@@ -68,6 +68,17 @@ pkgver() {
build() {
cd "$srcdir/${_gitname}"
+ # Add here stuff which may be needed to fix compilation errors because of warnings treated as error.
+ _FIXWERROR=""
+ # Silence compiler warnings
+ #_SILENCEWARNINGS="-Wno-deprecated-declarations -Wno-template-id-cdtor -Wno-unused-variable -Wno-unused-parameter"
+ _SILENCEWARNINGS="-w"
+ _CFLAGSADDITIONS=" ${_FIXWERROR} ${_SILENCEWARNINGS}"
+ CFLAGS+="${_CFLAGSADDITIONS}"
+ CXXFLAGS+="${_CFLAGSADDITIONS}"
+ export CFLAGS
+ export CXXFLAGS
+
qmake-qt5
make
@@ -78,16 +89,7 @@ package() {
cd "$srcdir/${_gitname}"
## Insall manually, since `DESTDIR` seems not to be honoured.
-
- # Install executable:
- install -Dvm755 -t "${pkgdir}/usr/bin" "bin/qmp3gain"
-
- # Install `.desktop` file, icons and sounds:
- install -Dvm644 -t "${pkgdir}/usr/share/applications" "resources/linux/applications"/qmp3gain.desktop
- for _resolution in "resources/linux/icons/hicolor"/*; do
- install -Dvm644 -t "${pkgdir}/usr/share/icons/hicolor/${_resolution}" "${_resolution}"/*.png
- done
- install -Dvm644 -t "${pkgdir}/usr/share/sounds/${_pkgname}" "resources/sounds"/*
+ INSTALL_ROOT="${pkgdir}" make install
# Install help files:
install -dvm755 "${pkgdir}/usr/share/doc/${_pkgname}"