aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagHSK2021-03-30 10:45:58 +0800
committerMagHSK2021-03-30 10:51:46 +0800
commit0ff2f2f501f4c42c07059a4687854a8a587ebc0b (patch)
tree9b9bb701ee0c334483428e556438e515f6582d5e
downloadaur-qnodeeditor.tar.gz
first commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD36
-rw-r--r--README.md1
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa6842d8a03e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = qnodeeditor
+ pkgdesc = Qt-based library aimed at graph-controlled data processing (qv2ray edition)
+ pkgver = 2.1.7
+ pkgrel = 1
+ url = https://github.com/Qv2ray/QNodeEditor
+ arch = x86_64
+ license = BSD
+ makedepends = cmake
+ depends = qt5-base
+ provides = nodeeditor
+ conflicts = nodeeditor
+ source = https://github.com/Qv2ray/QNodeEditor/archive/6f1d2f559bc9df42f9165067766f20578cf934e3.zip
+ sha256sums = e224ecf7d71880d297dd0f1e9b4a1bf6ebf6d1ae829d7a73a9744e5d67b0cd3f
+
+pkgname = qnodeeditor
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c8ef5144f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Han <maghsk2017@gmail.com>
+# Contributor: Mattéo Delabre <spam@delab.re>
+pkgname=qnodeeditor
+_reponame=QNodeEditor
+pkgver=2.1.7
+pkgrel=1
+pkgdesc="Qt-based library aimed at graph-controlled data processing (qv2ray edition)"
+arch=(x86_64)
+url="https://github.com/Qv2ray/QNodeEditor"
+license=(BSD)
+depends=(qt5-base)
+makedepends=(cmake)
+conflicts=('nodeeditor')
+provides=('nodeeditor')
+_commit=6f1d2f559bc9df42f9165067766f20578cf934e3
+source=("https://github.com/Qv2ray/$_reponame/archive/$_commit.zip")
+sha256sums=('e224ecf7d71880d297dd0f1e9b4a1bf6ebf6d1ae829d7a73a9744e5d67b0cd3f')
+
+build() {
+ cmake -B build -S "$_reponame-$_commit" \
+ -DBUILD_TESTING=ON \
+ -DBUILD_EXAMPLES=OFF \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ make -j -C build
+}
+
+check() {
+ make -j -C build test
+}
+
+package() {
+ make -j DESTDIR="$pkgdir/" -C build install
+ install -Dm 644 -t "$pkgdir/usr/share/licenses/nodeeditor" "$_reponame-$_commit/LICENSE"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..382994801620
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+This is a repo that maintains the AUR build files for [QNodeEditor](https://github.com/Qv2ray/QNodeEditor).