summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-06-20 14:18:22 -0700
committerxiota2023-06-20 14:18:22 -0700
commit2b38715c2d342a8f12faa1c55055df6f53cd27bd (patch)
tree9c4b253b966fc9de40f4ec869dad2aaec85de179
parentf034a3e82ed4c4119b1c1323e9b71fdaa6927722 (diff)
downloadaur-qogir-icon-theme-git.tar.gz
update makedepends
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 29 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 635919a16c2c..bf77f7bd6447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = qogir-icon-theme-git
pkgdesc = A colorful design icon theme for linux desktops
- pkgver = 2020.06.22.r15.g607a90bd
+ pkgver = 2023.06.05.r5.g7edbf61f
pkgrel = 1
url = https://github.com/vinceliuice/Qogir-icon-theme
arch = any
license = GPL3
makedepends = git
+ makedepends = gtk-update-icon-cache
provides = qogir-icon-theme
conflicts = qogir-icon-theme
options = !strip
- source = git+https://github.com/vinceliuice/Qogir-icon-theme
+ options = !debug
+ source = qogir-icon-theme::git+https://github.com/vinceliuice/Qogir-icon-theme
sha256sums = SKIP
pkgname = qogir-icon-theme-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 50d496d36b97..e55af42dcb87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,36 @@
-# Maintainer: Aitor Alonso <contact: https://aalonso.eu>
+# Maintainer:
+# Contributor: Aitor Alonso <contact: https://aalonso.eu>
-pkgname=qogir-icon-theme-git
-pkgver=2020.06.22.r15.g607a90bd
+_pkgname="qogir-icon-theme"
+pkgname="$_pkgname-git"
+pkgver=2023.06.05.r5.g7edbf61f
pkgrel=1
pkgdesc='A colorful design icon theme for linux desktops'
arch=('any')
url='https://github.com/vinceliuice/Qogir-icon-theme'
license=('GPL3')
+
depends=()
-makedepends=('git')
-optdepends=()
-provides=('qogir-icon-theme')
-conflicts=('qogir-icon-theme')
-options=('!strip')
-source=('git+https://github.com/vinceliuice/Qogir-icon-theme')
+makedepends=(
+ 'git'
+ 'gtk-update-icon-cache'
+)
+
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+
+options=(!strip !debug)
+
+source=("$_pkgname"::"git+$url")
sha256sums=('SKIP')
pkgver() {
- cd Qogir-icon-theme
+ cd "$srcdir/$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd Qogir-icon-theme
- mkdir -p "${pkgdir}/usr/share/icons"
- ./install.sh -d "${pkgdir}/usr/share/icons"
+ cd "$srcdir/$_pkgname"
+ mkdir -p "$pkgdir/usr/share/icons"
+ ./install.sh -d "$pkgdir/usr/share/icons"
}