summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2022-11-26 16:00:07 +0100
committerFabioLolix2022-11-26 16:00:07 +0100
commit4bcf5bb68f32416eb48b81101c1bb859fea32ebd (patch)
tree8b374337eec045d8d3167b337e7972cfd4daa662
parentd1f613c946b5a1f39bd8cee333b91533cf97fb40 (diff)
downloadaur-qomp.tar.gz
v1.5
-rwxr-xr-x.SRCINFO13
-rwxr-xr-xPKGBUILD42
2 files changed, 30 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 504452c07de0..a8c9dba400e1 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qomp
pkgdesc = Quick(Qt) Online Music Player
- pkgver = 1.4
- pkgrel = 3
+ pkgver = 1.5
+ pkgrel = 1
url = https://github.com/qomp/qomp
arch = i686
arch = x86_64
@@ -20,14 +20,15 @@ pkgbase = qomp
optdepends = gst-libav: additional codecs
optdepends = gst-plugins-bad: additional codecs
optdepends = gst-plugins-ugly: additional codecs
- source = git+https://github.com/qomp/qomp#tag=1.4
- source = git+https://github.com/qomp/translations
- source = git+https://github.com/qomp/themes
+ source = git+https://github.com/qomp/qomp.git#tag=1.5
+ source = qomp-translations::git+https://github.com/qomp/translations.git
+ source = qomp-themes::git+https://github.com/qomp/themes.git
+ source = git+https://github.com/wadealer/qt-google-analytics.git
source = git+https://github.com/wadealer/SingleApplication
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = SKIP
pkgname = qomp
-
diff --git a/PKGBUILD b/PKGBUILD
index 67091de6c282..5b26333f128c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Contributor: Alexander Bantyev <balsoft@yandex.ru>
pkgname=qomp
-pkgver=1.4
-pkgrel=3
+pkgver=1.5
+pkgrel=1
pkgdesc="Quick(Qt) Online Music Player"
arch=(i686 x86_64)
url="https://github.com/qomp/qomp"
@@ -16,36 +16,40 @@ optdepends=('gst-libav: additional codecs'
'gst-plugins-bad: additional codecs'
'gst-plugins-ugly: additional codecs')
makedepends=(git cmake qt5-tools)
-source=("git+https://github.com/qomp/qomp#tag=${pkgver}"
- "git+https://github.com/qomp/translations"
- "git+https://github.com/qomp/themes"
+source=("git+https://github.com/qomp/qomp.git#tag=${pkgver}"
+ "qomp-translations::git+https://github.com/qomp/translations.git"
+ "qomp-themes::git+https://github.com/qomp/themes.git"
+ "git+https://github.com/wadealer/qt-google-analytics.git"
"git+https://github.com/wadealer/SingleApplication")
sha256sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
prepare() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/qomp"
git submodule init
- git config 'submodule.translations.url' "${srcdir}/translations"
- git config 'submodule.themes.url' "${srcdir}/themes"
- git config 'submodule.src/singleapplication.url' "${srcdir}/SingleApplication"
- git submodule update
+ git config submodule.translations.url "${srcdir}/qomp-translations"
+ git config submodule.themes.url "${srcdir}/qomp-themes"
+ git config submodule.ga.url "${srcdir}/qt-google-analytics"
+ git config submodule.src/singleapplication.url "${srcdir}/SingleApplication"
+ git config submodule.android_openssl.update none
+ git -c protocol.file.allow=always submodule update
+ [[ -d build ]] || mkdir build
}
build() {
- cd "${srcdir}/${pkgname}"
-
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr/ \
+ cd "${srcdir}/qomp/build"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release
make
}
package() {
- cd "${srcdir}/${pkgname}"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/qomp/build"
+ make DESTDIR="$pkgdir/" install
}