summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmmon Smith2017-03-15 19:31:52 -0700
committerAmmon Smith2017-03-15 19:31:52 -0700
commit63a410c35a1f0cfbfdfc3040be4ecf095367f269 (patch)
tree8cb2dc9d99fb4a9b7ef547d9561b1bc022fba6c6
parentd5824d268a7ee012c60c5d877de965dc8fa46fe7 (diff)
downloadaur-63a410c35a1f0cfbfdfc3040be4ecf095367f269.tar.gz
Update PKGBUILD style.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 883c54194b14..1dd63689e999 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Feb 4 21:15:37 UTC 2017
+# Thu Mar 16 02:31:49 UTC 2017
pkgbase = qotd-git
pkgdesc = A simple RFC 865-compliant QOTD (quote of the day) daemon. (git version)
pkgver = 0.9.4_9_g7f1be22.7f1be22
diff --git a/PKGBUILD b/PKGBUILD
index f5ceaba8e119..ae5f028331f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,38 @@
# Maintainer: Ammon Smith <ammon.i.smith@gmail.com>
-_pkgname=qotd
-pkgname="$_pkgname-git"
+pkgname="qotd-git"
pkgver=0.9.4_9_g7f1be22.7f1be22
pkgrel=1
pkgdesc="A simple RFC 865-compliant QOTD (quote of the day) daemon. (git version)"
arch=('any')
-url="https://gitlab.com/ammongit/$_pkgname"
+url="https://gitlab.com/ammongit/${pkgname%-git}"
license=('GPL')
depends=()
makedepends=('git' 'gcc' 'ghostscript' 'gzip')
optdepends=()
-provides=("$_pkgname")
-conflicts=("$_pkgname")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
options=('!zipman')
install="$pkgname.install"
-source=("git+https://gitlab.com/ammongit/$_pkgname.git")
+source=("git+https://gitlab.com/ammongit/${pkgname%-git}.git")
sha256sums=('SKIP')
backup=('etc/qotd.conf')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/${pkgname%-git}"
local _ver="$(git describe --tags | sed 's/-/_/g')"
printf '%s.%s' "${_ver:1}" "$(git describe --always)"
}
build() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/${pkgname%-git}"
make release
}
package() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/${pkgname%-git}"
make ROOT="$pkgdir" SYSTEMD=1 install
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}
# vim: set sw=4 ts=4 noet: