summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin T. H. Sandsmark2021-10-25 18:09:43 +0200
committerMartin T. H. Sandsmark2021-10-25 18:09:43 +0200
commitf42c35ab07ca8941bf8011c3ae2cf96207b46477 (patch)
tree20ad7f3089d9b9b43559e17c037f7826f56c7fe0
downloadaur-qt-ffmpeg-imageplugin-git.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..338380d84e48
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt-ffmpeg-imageplugin-git
+ pkgdesc = Qt image plugin using ffmpeg for webm, apng, avif and more
+ pkgver = r30.33eea70
+ pkgrel = 1
+ url = https://github.com/sandsmark/qt-ffmpeg-imageplugin
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = cmake
+ depends = qt5-base
+ depends = ffmpeg
+ provides = qt-ffmpeg-imageplugin
+ conflicts = qt-ffmpeg-imageplugin
+ source = git+https://invent.kde.org/sandsmark/qt-ffmpeg-imageplugin.git
+ md5sums = SKIP
+
+pkgname = qt-ffmpeg-imageplugin-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c46e0c47164d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Martin Sandsmark <martin.sandsmark@kde.org>
+
+pkgname=qt-ffmpeg-imageplugin-git
+pkgver=r30.33eea70
+pkgrel=1
+pkgdesc='Qt image plugin using ffmpeg for webm, apng, avif and more'
+arch=('i686' 'x86_64')
+url='https://github.com/sandsmark/qt-ffmpeg-imageplugin'
+license=('LGPL')
+depends=('qt5-base' 'ffmpeg')
+makedepends=('git' 'cmake')
+conflicts=(qt-ffmpeg-imageplugin)
+provides=(qt-ffmpeg-imageplugin)
+source=('git+https://invent.kde.org/sandsmark/qt-ffmpeg-imageplugin.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd qt-ffmpeg-imageplugin
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd qt-ffmpeg-imageplugin
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd qt-ffmpeg-imageplugin
+ make DESTDIR="$pkgdir" install
+}