summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMuflone2024-03-10 04:14:36 +0100
committerMuflone2024-03-10 04:14:59 +0100
commit50af25a3d215ecaafc26d36c4454f82b47b05d69 (patch)
tree90b7fe1ddcafe3a83adbe38230b8fcb58d9281c8
parent75f1f25e68ea8c4c1f6acf0910ee36dbaa943cd4 (diff)
downloadaur-qt-installer-framework.tar.gz
Updated package qt-installer-framework 4.7.0-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--componentalias_const_qjsonarray.patch12
3 files changed, 31 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f479fc790638..5b02d0d95bbf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
pkgbase = qt-installer-framework
pkgdesc = The Qt Installer Framework used for the Qt SDK installer
- pkgver = 4.6.1
+ pkgver = 4.7.0
pkgrel = 1
url = http://qt-project.org/wiki/Qt-Installer-Framework
arch = x86_64
- license = FDL
- license = LGPL
+ license = GFDL-1.3-only
+ license = LicenseRef-GPL3-EXCEPT
makedepends = qt5-tools
makedepends = qt5-declarative
makedepends = clang
- source = qt-installer-framework-4.6.1.tar.gz::https://github.com/qtproject/installer-framework/archive/4.6.1.tar.gz
- sha256sums = ff2199ceb9ae996eebf18b0b737ee4fcf26c748988bb38cf7571115c21554d08
+ source = qt-installer-framework-4.7.0.tar.gz::https://github.com/qtproject/installer-framework/archive/4.7.0.tar.gz
+ source = componentalias_const_qjsonarray.patch
+ sha256sums = bb5cccd294fa357ca6571397e22adb8e88bf6827adf96d02152b95f01d4c4cb9
+ sha256sums = 7190ba7321dde12b4b13963f1b6d94f10299766980578f2498f21f985a4f2e46
pkgname = qt-installer-framework
pkgdesc = The Qt Installer Framework used for the Qt SDK installer
diff --git a/PKGBUILD b/PKGBUILD
index e341cfe6dacf..7698f372c1e0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,29 @@
pkgbase=qt-installer-framework
pkgname=(qt-installer-framework qt-installer-framework-docs)
-pkgver=4.6.1
+pkgver=4.7.0
pkgrel=1
pkgdesc='The Qt Installer Framework used for the Qt SDK installer'
arch=('x86_64')
url='http://qt-project.org/wiki/Qt-Installer-Framework'
-license=('FDL' 'LGPL')
+license=('GFDL-1.3-only' 'LicenseRef-GPL3-EXCEPT')
makedepends=('qt5-tools' 'qt5-declarative' 'clang')
-source=("${pkgbase}-${pkgver}.tar.gz"::"https://github.com/qtproject/installer-framework/archive/${pkgver}.tar.gz")
-sha256sums=('ff2199ceb9ae996eebf18b0b737ee4fcf26c748988bb38cf7571115c21554d08')
+source=("${pkgbase}-${pkgver}.tar.gz"::"https://github.com/qtproject/installer-framework/archive/${pkgver}.tar.gz"
+ "componentalias_const_qjsonarray.patch")
+sha256sums=('bb5cccd294fa357ca6571397e22adb8e88bf6827adf96d02152b95f01d4c4cb9'
+ '7190ba7321dde12b4b13963f1b6d94f10299766980578f2498f21f985a4f2e46')
+
+prepare() {
+ cd "installer-framework-${pkgver}"
+ patch -p1 -i "${srcdir}/componentalias_const_qjsonarray.patch"
+}
build() {
# Build tools and libraries
cd "installer-framework-${pkgver}"
qmake .
make
- make docs
+ make html_docs_ifw
}
package_qt-installer-framework() {
@@ -62,6 +69,4 @@ package_qt-installer-framework-docs() {
# Install documentation
install -m 755 -d "${pkgdir}/usr/share/doc/${pkgbase}"
cp -a "doc/html" "${pkgdir}/usr/share/doc/${pkgbase}"
- install -m 755 -d "${pkgdir}/usr/share/doc/qt"
- install -m 644 -t "${pkgdir}/usr/share/doc/qt" "doc/ifw.qch"
}
diff --git a/componentalias_const_qjsonarray.patch b/componentalias_const_qjsonarray.patch
new file mode 100644
index 000000000000..c2452fc5dfad
--- /dev/null
+++ b/componentalias_const_qjsonarray.patch
@@ -0,0 +1,12 @@
+diff -Naur installer-framework-4.7.0.orig/src/libs/installer/componentalias.cpp installer-framework-4.7.0/src/libs/installer/componentalias.cpp
+--- installer-framework-4.7.0.orig/src/libs/installer/componentalias.cpp 2024-02-15 07:00:18.000000000 +0100
++++ installer-framework-4.7.0/src/libs/installer/componentalias.cpp 2024-03-10 03:21:06.850953720 +0100
+@@ -295,7 +295,7 @@
+ const QJsonObject docJsonObject = doc.object();
+
+ const QJsonArray aliases = docJsonObject.value(QLatin1String("alias-packages")).toArray();
+- for (auto &it : aliases) {
++ for (const auto &it : aliases) {
+ AliasData data;
+ data.insert(QLatin1String("source"), QVariant::fromValue(source));
+