aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2021-09-04 11:43:14 -0700
committerDonald Carr2021-09-04 11:43:40 -0700
commit2fe04ee6f45dc023464ac33caad473d2b23df366 (patch)
tree918566a750e7cddde46eaea2d752471bec55b9fa
parentd3cbe2f6150de747bc501486ce2efc967d11d791 (diff)
downloadaur-2fe04ee6f45dc023464ac33caad473d2b23df366.tar.gz
Update to Qt 6.2.0
Change-Id: I0819f50fd708a11ccdbd8fa995ab82ef92dde239
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD47
2 files changed, 14 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3983b4d1b7d..8cf31ab35c8c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt-sdk
pkgdesc = Qt SDK for both hosts and a variety of targets
- pkgver = 6.1.0
+ pkgver = 6.2.0
pkgrel = 4
url = http://www.chaos-reins.com/qpi/
arch = x86_64
@@ -18,9 +18,8 @@ pkgbase = qt-sdk
provides = qt-sdk
options = !strip
source = git://github.com/sirspudd/mkspecs.git
- source = https://download.qt.io/development_releases/qt/6.1/6.1.0-beta3/single/qt-everywhere-src-6.1.0-beta3.tar.xz
+ source = https://download.qt.io/development_releases/qt/6.2/6.2.0-beta3/single/qt-everywhere-src-6.2.0-beta3.tar.xz
sha256sums = SKIP
sha256sums = SKIP
pkgname = qt-sdk
-
diff --git a/PKGBUILD b/PKGBUILD
index 30f73c2e4be4..915b69a83d95 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,7 @@
# Maintainer: Donald Carr <d at chaos-reins dot com>
+# Cross compilation is currently broken due to Qt 6 changes
+
#set -x
# Documentation
@@ -17,7 +19,7 @@
# NB: Mandatory edit: set this variable to point to your raspberry pi's sysroot
# Arch: build dependencies for the target device documented in PKGBUILD.libs
-# Fedora: systemd-devel mesa-*-devel wayland*-devel fontconfig-devel libinput-devel freetype-devel qt5-qtdeclarative-devel
+# Fedora: systemd-devel mesa-*-devel wayland*-devel fontconfig-devel libinput-devel freetype-devel qt-qtdeclarative-devel
pkgname="qt-sdk"
@@ -34,8 +36,7 @@ _float=false
_shadow_build=true
# automatically disabled if you are building webengine
_debug=true
-_skip_qtscript=false
-_skip_qtwebengine=false
+_skip_qtwebengine=true
_skip_qtwidgets=false
_static_build=false
_build_from_local_src_tree=false
@@ -116,9 +117,9 @@ if $_building && [[ -n $LOCAL_PI_VER ]]; then
fi
# vars
-_local_qt5_repo="${local_qt5_repo}"
+_local_qt_repo="${local_qt_repo}"
#_pkgvermajmin="5.15"
-_pkgvermajmin="6.1"
+_pkgvermajmin="6.2"
_pkgverpatch=".0"
# {alpha/beta/beta2/rc}
_dev_suffix="beta3"
@@ -160,13 +161,7 @@ if [[ -f debug ]]; then
_debug=true
fi
-if $_building && $_minimal; then
- _skip_qtscript=true
- _skip_qtwebengine=true
-fi
-
$_skip_qtwebengine && _additional_configure_flags="$_additional_configure_flags -skip qtwebengine -no-icu"
-$_skip_qtscript && _additional_configure_flags="$_additional_configure_flags -skip qtscript"
$_skip_qtwidgets && _additional_configure_flags="$_additional_configure_flags -no-widgets"
$_static_build && _additional_configure_flags="$_additional_configure_flags -static -ltcg"
$_float && _additional_configure_flags="$_additional_configure_flags -qreal float"
@@ -193,17 +188,6 @@ makedepends=("git" "pkgconfig" "gcc" "gperf" "python" "clang" "cmake" "ninja")
_provider=https://download.qt.io
_tmpfs_dir=/vortex/build
-_arch_specific_configure_options="\
- -prefix /usr \
- -docdir /usr/share/doc/qt \
- -headerdir /usr/include/qt \
- -archdatadir /usr/lib/qt \
- -datadir /usr/share/qt \
- -sysconfdir /etc/xdg \
- -examplesdir /usr/share/doc/qt/examples \
- -no-rpath \
-"
-
retired_exhaustive_uber_minimal_specific_configure_options="\
-no-linuxfb \
"
@@ -233,8 +217,12 @@ if $_uber_minimal; then
"
fi
+ # Too bleeding big
+ # -developer-build \
+
#-journald \
_core_configure_options=" \
+ -separate-debug-info \
-qt-harfbuzz \
-qt-pcre \
-pkg-config \
@@ -301,8 +289,8 @@ adjust_bin_dir() {
adjust_src_dir() {
if $_build_from_local_src_tree; then
- if [[ -z $_local_qt5_repo ]]; then echo "Need to set a repo dir to build from head"; exit 1; fi
- _srcdir=$_local_qt5_repo
+ if [[ -z $_local_qt_repo ]]; then echo "Need to set a repo dir to build from head"; exit 1; fi
+ _srcdir=$_local_qt_repo
fi
}
@@ -336,9 +324,6 @@ if $_uber_minimal; then
cat $_tmp_qtpro >> $_qtpro
fi
- # enable reduce relocations
- sed -i '/error Symbolic function binding/d' ${_srcdir}/qtbase/configure.json
-
if ! $_target_host && $_overwrite_mkspec; then
# Get our mkspec
mkdir -p $_mkspec_dir
@@ -349,13 +334,6 @@ fi
mkdir -p ${_bindir}
cd ${_bindir}
- # Too bleeding big
- # -developer-build \
- # -separate-debug-info \
-
- # Chromium requires python2 to be the system python on your build host
- # I literally symlink /usr/bin/python to /usr/bin/python2 on arch
-
# Just because you can enable something doesnt mean you should
# Prepare for breakage in all your Qt derived projects
#-qtnamespace "Pi${_piver}" \
@@ -365,7 +343,6 @@ if $_target_host; then
-platform linux-clang-libc++ \
${_core_configure_options} \
${_additional_configure_flags}"
-# ${_arch_specific_configure_options} \
else
# Fuck debian multi-arch dead
export PKG_CONFIG_LIBDIR=${_sysroot}/usr/lib/$(${_toolchain}gcc -dumpmachine)/pkgconfig/:${_sysroot}/usr/lib/pkgconfig/