aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2021-09-27 19:40:28 -0700
committerDonald Carr2021-09-27 19:40:28 -0700
commit87dbed5f909a233073891263e4d0795053c8efac (patch)
treee3fb963a3a3eea2b3fa012cc1724337cec12574e
parentc9596ff952838b30c203e0b7fed38817201bbc79 (diff)
downloadaur-87dbed5f909a233073891263e4d0795053c8efac.tar.gz
Move to 6.2.0 rc2
Change-Id: I19ad962350caf2264c865ca74dcfbaea7370fe3c
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f34876596693..e28376faa5f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt-sdk
pkgdesc = Qt SDK for both hosts and a variety of targets
pkgver = 6.2.0
- pkgrel = 5
+ pkgrel = 6
url = http://www.chaos-reins.com/qpi/
arch = x86_64
license = LGPL3
@@ -14,11 +14,14 @@ pkgbase = qt-sdk
makedepends = clang
makedepends = cmake
makedepends = ninja
+ makedepends = libc++
+ makedepends = pcre
+ makedepends = harfbuzz
optdepends = qtcreator: Integrated IDE development
provides = qt-sdk
options = !strip
source = git://github.com/sirspudd/mkspecs.git
- source = https://download.qt.io/development_releases/qt/6.2/6.2.0-beta3/single/qt-everywhere-src-6.2.0-beta3.tar.xz
+ source = https://download.qt.io/development_releases/qt/6.2/6.2.0-rc2/single/qt-everywhere-src-6.2.0-rc2.tar.xz
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 5e727d74f94e..cff31063da83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -122,8 +122,8 @@ _local_qt_repo="${local_qt_repo}"
_pkgvermajmin="6.2"
_pkgverpatch=".0"
# {alpha/beta/beta2/rc}
-_dev_suffix="beta3"
-pkgrel=5
+_dev_suffix="rc2"
+pkgrel=6
pkgver="${_pkgvermajmin}${_pkgverpatch}"
$_build_from_local_src_tree && pkgver=6.6.6
_pkgver=${pkgver}
@@ -183,7 +183,7 @@ arch=("x86_64")
url="http://www.chaos-reins.com/qpi/"
license=("LGPL3" "GPL3")
optdepends=('qtcreator: Integrated IDE development')
-makedepends=("git" "pkgconfig" "gcc" "gperf" "python" "clang" "cmake" "ninja")
+makedepends=("git" "pkgconfig" "gcc" "gperf" "python" "clang" "cmake" "ninja" "libc++" "pcre" "harfbuzz")
#_provider=http://qt.mirror.constant.com/
_provider=https://download.qt.io
_tmpfs_dir=/vortex/build
@@ -210,7 +210,6 @@ if $_uber_minimal; then
-no-sql-mysql \
-no-sql-psql \
-no-tslib \
- -no-feature-bearermanagement \
-no-qml-debug \
-no-ico \
-no-glib \
@@ -220,11 +219,8 @@ fi
# Too bleeding big
# -developer-build \
-#-journald \
_core_configure_options=" \
-separate-debug-info \
- -qt-harfbuzz \
- -qt-pcre \
-pkg-config \
-prefix ${_installprefix} \
-opengl ${_opengl_variant} \
@@ -340,6 +336,8 @@ fi
if $_target_host; then
local _configure_line="${_srcdir}/configure \
-platform linux-clang-libc++ \
+ -xplatform linux-clang-libc++ \
+ -linker lld \
${_core_configure_options} \
${_additional_configure_flags}"
else