aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-06-06 12:50:43 -0700
committerDonald Carr2016-06-07 12:34:11 -0700
commit0dc3e482cf792783f50e459ca9d5b91b2a405594 (patch)
tree054f10e5717819701d9053f4a130176d5de91f61
parent75342feeeb6535f49719714b40797c2d8809abdf (diff)
downloadaur-0dc3e482cf792783f50e459ca9d5b91b2a405594.tar.gz
Namespacing is now fixed
Introducing shadow build option for the day it works again (Wayland module still broken)
-rw-r--r--PKGBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d2641a7fcbe..d75773329e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,7 @@
_sysroot=/mnt/pi
# Options
+_shadow_build=false
_release=true
_skip_web_engine=false
_static_build=false
@@ -115,28 +116,32 @@ if $_build_from_head; then
fi
build() {
+ # Qt tries to do the right thing and stores these, breaking cross compilation
+ unset LDFLAGS
+ unset CFLAGS
+ unset CXXFLAGS
+
if [[ -z "$_piver" ]]; then
echo "Set a pi version to build the associated sdk"
exit -1
fi
local _srcdir="${srcdir}/${_source_package_name}"
+ local _bindir="${_srcdir}"
local _basedir="${_srcdir}/qtbase"
local _waylanddir="${_srcdir}/qtwayland"
local _webenginedir="${_srcdir}/qtwebengine"
local _locationdir="${_srcdir}/qtlocation"
- local _bindir="${_srcdir}"
local _mkspec_dir="${_basedir}/mkspecs/devices/${_mkspec}"
- # Qt tries to do the right thing and stores these, breaking cross compilation
- unset LDFLAGS
- unset CFLAGS
- unset CXXFLAGS
-
if $_build_from_head; then
_srcdir="${_local_qt5_repo}"
fi
+if $_shadow_build; then
+ _bindir="${_srcdir}-build"
+fi
+
cd ${_srcdir}
# Get our mkspec
@@ -163,12 +168,13 @@ fi
# Work around our embarresing propensity to stomp on your own tailored build configuration
sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1
+ if $_shadow_build; then
+ rm -Rf ${_bindir}
+ fi
+
mkdir -p ${_bindir}
cd ${_bindir}
- # Breaks in qtwayland
- # -qtnamespace Pi \
-
${_srcdir}/configure \
-no-icu \
-v \
@@ -177,6 +183,7 @@ fi
-silent \
-confirm-license \
-opensource \
+ -qtnamespace "Pi${_piver}" \
-qtlibinfix "Pi${_piver}" \
-reduce-exports \
-reduce-relocations \
@@ -215,6 +222,10 @@ package() {
local _srcdir="${srcdir}/${_source_package_name}"
local _bindir="${_srcdir}"
+if $_shadow_build; then
+ _bindir="${_srcdir}-build"
+fi
+
create_install_script
# cleanup