aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2018-04-05 01:51:23 -0700
committerDonald Carr2018-04-05 01:51:23 -0700
commit14dc33f5b9f26db4e2d31f39eac88e268fa5f439 (patch)
tree0e034eb54527f1619933c6146f19474e38c89e82
parent145b30657df69684cd7d3a27a08125ece4aa57d7 (diff)
downloadaur-14dc33f5b9f26db4e2d31f39eac88e268fa5f439.tar.gz
Enable desktop GL on the raspberry pi 3 aarch VC4 stack
projectmofo requires it
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 49b42d4d4aab..7fc78c941b62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -109,6 +109,11 @@ __pkgconfigpath=${_sysroot}/usr/lib/pkgconfig
__eglpkgconfigpath="${__pkgconfigpath}/egl.pc"
__glespkgconfigpath="${__pkgconfigpath}/glesv2.pc"
+_opengl_variant="desktop"
+if [ -n "${_piver}" ]; then
+ _opengl_variant="gles2"
+fi
+
case ${_piver} in
1)
_toolchain_name=armv6-rpi-linux-gnueabihf
@@ -127,6 +132,8 @@ case ${_piver} in
_toolchain="/opt/x-tools/${_toolchain_name}/bin/${_toolchain_name}-"
_use_mesa=true
_mkspec="linux-rpi${_piver}-g++"
+ # just for projectmofo!
+ _opengl_variant="desktop"
;;
4)
# yuck; here lies tinkerboard until I find a better way of generalizing this
@@ -244,6 +251,7 @@ if $_uber_minimal; then
_additional_configure_flags="$_additional_configure_flags $_exhaustive_uber_minimal_specific_configure_options"
_additional_configure_flags="$_additional_configure_flags \
+ -opengl ${_opengl_variant} \
-no-ico \
-no-glib \
-no-fontconfig \
@@ -403,7 +411,6 @@ fi
# -platform linux-clang \
if $_target_host; then
local _configure_line="${_srcdir}/configure \
- -opengl desktop \
${_core_configure_options} \
${_additional_configure_flags}"
# ${_arch_specific_configure_options} \
@@ -417,7 +424,6 @@ else
-device-option CROSS_COMPILE=${_toolchain} \
-no-xcb \
-qpa eglfs \
- -opengl es2 \
-egl \
${_additional_configure_flags}"
fi