aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-09-11 18:12:22 -0700
committerDonald Carr2016-09-12 01:39:52 -0700
commit6c80bfb5952f37321e65774678682265300182d3 (patch)
tree43d93f0afd9dac14a7aaea2a4f18f066d2df9d67
parentace713d2611dcd3a8231e98fe9d48914d63dc6fc (diff)
downloadaur-6c80bfb5952f37321e65774678682265300182d3.tar.gz
test lib64 pkgconfig patch
Change-Id: I390ef8767d6d3fdbfe04711d230b5e152e62c4e0
-rw-r--r--0001-Check-lib64-as-well-as-lib.patch46
-rw-r--r--PKGBUILD3
2 files changed, 49 insertions, 0 deletions
diff --git a/0001-Check-lib64-as-well-as-lib.patch b/0001-Check-lib64-as-well-as-lib.patch
new file mode 100644
index 000000000000..41b2c2306a47
--- /dev/null
+++ b/0001-Check-lib64-as-well-as-lib.patch
@@ -0,0 +1,46 @@
+From 2586eaac76349843ed573e8e7c24761d343a8b42 Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Sun, 11 Sep 2016 18:10:14 -0700
+Subject: [PATCH] Check lib64 as well as lib
+
+Change-Id: I3a875a215e8524e5b1f2d5222ef3134bc1aa719f
+---
+ configure.pri | 15 +++++++++++----
+ 1 file changed, 11 insertions(+), 4 deletions(-)
+
+diff --git a/configure.pri b/configure.pri
+index 6a75398..2240dea 100644
+--- a/configure.pri
++++ b/configure.pri
+@@ -148,17 +148,24 @@ defineTest(qtConfTest_detectPkgConfig) {
+ qtConfAddWarning("Cross compiling without sysroot. Disabling pkg-config")
+ return(false)
+ }
+- !exists("$$sysroot/usr/lib/pkgconfig") {
++ exists("$$sysroot/usr/lib/pkgconfig") {
++ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/lib/pkgconfig"
++ }
++ exists("$$sysroot/usr/lib64/pkgconfig") {
++ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/lib64/pkgconfig"
++ }
++
++ isEmpty(pkgConfigLibdir) {
+ qtConfAddWarning( \
+- "Disabling pkg-config since PKG_CONFIG_LIBDIR is not set and" \
+- "the host's .pc files would be used (even if you set PKG_CONFIG_PATH)." \
++ "Disabling pkg-config since PKG_CONFIG_LIBDIR is not set and cant be inferred." \
++ "The host's .pc files would be used (even if you set PKG_CONFIG_PATH)." \
+ "Set this variable to the directory that contains target .pc files" \
+ "for pkg-config to function correctly when cross-compiling or" \
+ "use -pkg-config to override this test.")
+ return(false)
+ }
+
+- pkgConfigLibdir = $$sysroot/usr/lib/pkgconfig:$$sysroot/usr/share/pkgconfig
++ pkgConfigLibdir = "$$pkgConfigLibdir:$$sysroot/usr/share/pkgconfig"
+ gcc {
+ qtRunLoggedCommand("$$QMAKE_CXX -dumpmachine", gccMachineDump): \
+ !isEmpty(gccMachineDump): \
+--
+2.9.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 6024598e8c73..0d2efa2e4060 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -188,6 +188,9 @@ if $_patching; then
#sed -i "s/error/warning/" ${_reducerelocations} || exit 1
#_device_configure_flags="$_device_configure_flags -reduce-relocations"
+ cd ${_basedir}
+ patch -p1 < ${startdir}/0001-Check-lib64-as-well-as-lib.patch
+
cd ${_declarativedir}
patch -p1 < ${startdir}/0001-WIP-V4-Free-up-2-address-bits-in-64bit-mode.patch