aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-05-31 18:18:50 -0700
committerDonald Carr2017-05-31 18:18:50 -0700
commit7d792212568e218cdd866abff0d1c0b7860ec683 (patch)
treec94cd8fdc27256460e46332766ca3dd8406ab07c
parent9eeb37be80aec4db8d99ba3aefe97ca8e6b91fff (diff)
downloadaur-7d792212568e218cdd866abff0d1c0b7860ec683.tar.gz
Move off clang until dust settles
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0195b8821302..3d23d0b22d00 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -177,6 +177,7 @@ _core_configure_options="\
-prefix ${_installprefix} \
-optimized-tools \
-optimized-qmake \
+ -optimize-size \
-confirm-license \
-opensource \
-v \
@@ -294,14 +295,6 @@ if $_patching; then
#cd ${_webenginedir}
# reverse patch which breaks dynamic loading of EGL/GLESvs with rpi proprietary drivers
#patch -p1 < ${startdir}/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch
-
- # Work around our embarresing propensity to stomp on your own tailored build configuration
- # Now also present as we get complaints on the RPI 1 when Qt is left to use O3 about the
- # lack of NEON intrinsics
- # Couple with that the fact clang does not appear to consider -Os legitimate
- if ! $_target_host; then
- sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1
- fi
fi
rm -Rf ${_bindir}
@@ -319,9 +312,9 @@ fi
# Prepare for breakage in all your Qt derived projects
#-qtnamespace "Pi${_piver}" \
+# -platform linux-clang \
if $_target_host; then
local _configure_line="${_srcdir}/configure \
- -platform linux-clang \
-make tools \
${_core_configure_options} \
${_additional_configure_flags}"