aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-05-22 13:50:25 -0700
committerDonald Carr2017-05-22 13:50:25 -0700
commit9161024ae0b2b44adbb61bc9cd290cc687392381 (patch)
treea5dd59512c926de746b26fbf04c7c896de253e02
parent654ede1a77ad67b3efc5ce1ae266e2625916024a (diff)
downloadaur-9161024ae0b2b44adbb61bc9cd290cc687392381.tar.gz
Raspberry Pi 1 build is always minimal
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 317994f88c66..0fafbc9efe8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,13 +48,6 @@ if [[ -f full-build ]]; then
_debug=false
fi
-if $_building && $_minimal; then
- _skip_qtscript=true;
- _skip_web_engine=true;
- _skip_qt_widgets=true;
- pkgname="${pkgname}-minimal"
-fi
-
# Sanity check options
if $_building; then
if [[ -z $_piver ]] && [[ -n $LOCAL_PI_VER ]]; then _piver=$LOCAL_PI_VER; fi
@@ -96,7 +89,8 @@ __glespkgconfigpath="${__pkgconfigpath}/glesv2.pc"
case ${_piver} in
1)
_toolchain_name=armv6-rpi-linux-gnueabihf
- _skip_web_engine=true
+ _minimal=true
+ _float=true
;;
2)
_toolchain_name=armv7-rpi2-linux-gnueabihf
@@ -104,10 +98,16 @@ case ${_piver} in
3)
_toolchain_name=aarch64-rpi3-linux-gnueabi
_use_mesa=true
- _float=false
;;
esac
+if $_building && $_minimal; then
+ _skip_qtscript=true;
+ _skip_web_engine=true;
+ _skip_qt_widgets=true;
+ pkgname="${pkgname}-minimal"
+fi
+
if $_target_host; then
_use_mesa=true
else