aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2017-05-28 16:00:30 -0700
committerDonald Carr2017-05-28 16:00:30 -0700
commitc554e4f10cd0534da046c936c24d7db38e2bd9cd (patch)
treeba1b9eb85eaa7ebc40bc2bdc6c4dad5573021060
parenta0f795aa1a928612b5c1280f7c606aa13fe6199a (diff)
downloadaur-c554e4f10cd0534da046c936c24d7db38e2bd9cd.tar.gz
Don't use Os with clang
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3f9851368c4..ef2cab954d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -295,7 +295,12 @@ if $_patching; then
patch -p1 < ${startdir}/0001-Revert-Fully-qualify-libEGL.so.1-libEGLESv2.so.2-lib.patch
# Work around our embarresing propensity to stomp on your own tailored build configuration
- sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1
+ # Now also present as we get complaints on the RPI 1 when Qt is left to use O3 about the
+ # lack of NEON intrinsics
+ # Couple with that the fact clang does not appear to consider -Os legitimate
+ if ! $_target_host; then
+ sed -i "s/O[23]/Os/" ${_basedir}/mkspecs/common/gcc-base.conf || exit 1
+ fi
fi
rm -Rf ${_bindir}