summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-03-15 11:37:07 -0700
committerDonald Carr2016-03-15 15:51:50 -0700
commit376b81dc0c11ddd0e8f403e5ea253dd98dbd842a (patch)
treeb23fe6d291f5b28485a4dc0cc2eaf618f856385d
parentfa0921d272d4fb9f49bfab6ed5f85fa9684d3e9c (diff)
downloadaur-376b81dc0c11ddd0e8f403e5ea253dd98dbd842a.tar.gz
Move to in source build to get qtwayland compiling
-rw-r--r--0001-Adjust-Raspberry-Pi-integration-to-new-API.patch83
-rw-r--r--PKGBUILD29
2 files changed, 97 insertions, 15 deletions
diff --git a/0001-Adjust-Raspberry-Pi-integration-to-new-API.patch b/0001-Adjust-Raspberry-Pi-integration-to-new-API.patch
new file mode 100644
index 000000000000..cde586635873
--- /dev/null
+++ b/0001-Adjust-Raspberry-Pi-integration-to-new-API.patch
@@ -0,0 +1,83 @@
+From 83c85fa8d7f69890e85018cf8e45d8b2e98b3486 Mon Sep 17 00:00:00 2001
+From: Donald Carr <sirspudd@gmail.com>
+Date: Tue, 15 Mar 2016 13:25:36 -0700
+Subject: [PATCH] Adjust Raspberry Pi integration to new API
+
+Change-Id: I7ef64e5dd5e87e62ec83fc05076a5c2e93d11638
+---
+ src/hardwareintegration/compositor/brcm-egl/brcm-egl.pri | 2 +-
+ .../compositor/brcm-egl/brcmeglintegration.cpp | 10 ++--------
+ .../compositor/brcm-egl/brcmeglintegration.h | 3 +--
+ 3 files changed, 4 insertions(+), 11 deletions(-)
+
+diff --git a/src/hardwareintegration/compositor/brcm-egl/brcm-egl.pri b/src/hardwareintegration/compositor/brcm-egl/brcm-egl.pri
+index 83c7b62..f478071 100644
+--- a/src/hardwareintegration/compositor/brcm-egl/brcm-egl.pri
++++ b/src/hardwareintegration/compositor/brcm-egl/brcm-egl.pri
+@@ -1,4 +1,4 @@
+-QT = compositor compositor-private core-private gui-private
++QT = waylandcompositor waylandcompositor-private core-private gui-private
+
+ INCLUDEPATH += $$PWD
+
+diff --git a/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.cpp b/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.cpp
+index 08df635..508e882 100644
+--- a/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.cpp
++++ b/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.cpp
+@@ -36,7 +36,6 @@
+
+ #include "brcmeglintegration.h"
+ #include "brcmbuffer.h"
+-#include <QtWaylandCompositor/private/qwlsurface_p.h>
+ #include <QtWaylandCompositor/qwaylandsurface.h>
+ #include <qpa/qplatformnativeinterface.h>
+ #include <QtGui/QGuiApplication>
+@@ -76,7 +75,7 @@ BrcmEglIntegration::BrcmEglIntegration()
+ {
+ }
+
+-void BrcmEglIntegration::initializeHardware(QtWayland::Display *waylandDisplay)
++void BrcmEglIntegration::initializeHardware(struct ::wl_display *display)
+ {
+ Q_D(BrcmEglIntegration);
+
+@@ -114,7 +113,7 @@ void BrcmEglIntegration::initializeHardware(QtWayland::Display *waylandDisplay)
+ return;
+ }
+ d->valid = true;
+- init(waylandDisplay->handle(), 1);
++ init(display, 1);
+ }
+ }
+
+@@ -147,11 +146,6 @@ void BrcmEglIntegration::bindTextureToBuffer(struct ::wl_resource *buffer)
+ d->eglDestroyImageKHR(d->egl_display, image);
+ }
+
+-bool BrcmEglIntegration::isYInverted(struct ::wl_resource *) const
+-{
+- return false;
+-}
+-
+ void BrcmEglIntegration::brcm_bind_resource(Resource *)
+ {
+ }
+diff --git a/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.h b/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.h
+index 90f447c..48dd9c4 100644
+--- a/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.h
++++ b/src/hardwareintegration/compositor/brcm-egl/brcmeglintegration.h
+@@ -52,10 +52,9 @@ class BrcmEglIntegration : public QtWayland::ClientBufferIntegration, public QtW
+ public:
+ BrcmEglIntegration();
+
+- void initializeHardware(QtWayland::Display *waylandDisplay) Q_DECL_OVERRIDE;
++ void initializeHardware(struct ::wl_display *display) Q_DECL_OVERRIDE;
+
+ void bindTextureToBuffer(struct ::wl_resource *buffer) Q_DECL_OVERRIDE;
+- bool isYInverted(struct ::wl_resource *) const Q_DECL_OVERRIDE;
+
+ QSize bufferSize(struct ::wl_resource *buffer) const Q_DECL_OVERRIDE;
+
+--
+2.7.3
+
diff --git a/PKGBUILD b/PKGBUILD
index 8a8cd49fc737..680c1e088057 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,14 +22,12 @@ _skip_web_engine=false
_static_build=false
_build_from_head=false
_local_qt5_repo="/opt/dev/src/qtproject/qt5"
-_wayland_compositor_workaround=true
+_wayland_compositor_workaround=false
-_pkgvermajmin="5.6"
+_pkgvermajmin="5.7"
pkgver="${_pkgvermajmin}.0"
-# 5.6: 12
-# 5.7: 1
-pkgrel=13
+pkgrel=2
# PKGBUILD
_piver=2
@@ -49,16 +47,16 @@ _packaginguser=$(whoami)
_libspkgname="${pkgname}-target-libs"
_mkspec="linux-rpi${_piver}-g++"
-_pkgver=${pkgver}-rc
-#_pkgver=${pkgver}-alpha
+_pkgver=${pkgver}-alpha
_baseprefix=/opt
_installprefix=${_baseprefix}/${pkgname}
_qt_package_name_prefix="qt-everywhere-opensource-src"
_source_package_name=${_qt_package_name_prefix}-${_pkgver}
-_source_unpackaged_name=${_source_package_name}
-#_source_unpackaged_name=${_qt_package_name_prefix}-${pkgver}
+# Work around packaging bug (lack of postfix in 5.7.0-alpha)
+#_source_unpackaged_name=${_source_package_name}
+_source_unpackaged_name=${_qt_package_name_prefix}-${pkgver}
pkgdesc="Qt SDK for the Raspberry Pi${_piver}"
arch=("x86_64")
@@ -68,8 +66,7 @@ depends=("qpi-toolchain" "qtcreator")
makedepends=("git" "pkgconfig" "gcc")
source=("git://github.com/sirspudd/mkspecs.git" "https://download.qt.io/development_releases/qt/${_pkgvermajmin}/${_pkgver}/single/${_source_package_name}.7z")
-sha256sums=("SKIP" "82ed4bc1bf7735747e1612f322f8723dfd84f05fa4dca9398863e6527a0c1971")
-#sha256sums=("SKIP" "5d8d12bc72f12532323737894beadd0d0021ee1b4321e53798e722b0352bbc24")
+sha256sums=("SKIP" "5d8d12bc72f12532323737894beadd0d0021ee1b4321e53798e722b0352bbc24")
options=('!strip')
install=qpi.install
@@ -110,12 +107,13 @@ if $_wayland_compositor_workaround; then
fi
# bug(s) in Qt 5.7.0-alpha
-#_device_configure_flags="$_device_configure_flags -skip qtlocation -skip qtwayland"
+_device_configure_flags="$_device_configure_flags -skip qtlocation"
build() {
local _srcdir="${srcdir}/${_source_unpackaged_name}"
local _basedir="${_srcdir}/qtbase"
- local _bindir="${_srcdir}-build"
+ local _waylanddir="${_srcdir}/qtwayland"
+ local _bindir="${_srcdir}"
local _mkspec_dir="${_basedir}/mkspecs/devices/${_mkspec}"
# Qt tries to do the right thing and stores these, breaking cross compilation
@@ -156,8 +154,9 @@ fi
# incorporate journald fix
local _patch_dir=${startdir}
cd ${_basedir}
- patch -p1 < ${_patch_dir}/0001-Search-for-libsystemd-first-fall-back-to-libsystemd-.patch
patch -p1 < ${_patch_dir}/0001-journald-test-will-fail-with-certain-toolchains.patch
+ cd ${_waylanddir}
+ patch -p1 < ${_patch_dir}/0001-Adjust-Raspberry-Pi-integration-to-new-API.patch
# end patch
@@ -221,7 +220,7 @@ create_install_script()
package() {
local _srcdir="${srcdir}/${_source_unpackaged_name}"
- local _bindir="${_srcdir}-build"
+ local _bindir="${_srcdir}"
create_install_script