summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDonald Carr2016-01-25 16:46:39 -0800
committerDonald Carr2016-01-25 18:52:04 -0800
commit82fc4ab3145422692fc5cb021f052a6d72f030a8 (patch)
tree6c8af1ee63d5eba46658cc62896a9e07b5d4e317
parenta8026cb7eadbddfdad6eddc1cab9379c1eb522b9 (diff)
downloadaur-82fc4ab3145422692fc5cb021f052a6d72f030a8.tar.gz
Make the building of webengine a conscious decision
Change-Id: I23d1c54b8266da0b7d2326801832770e1d582f2e
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 141836c0acc7..c53d1956fbef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,6 +18,10 @@
# Mount/copy this prepped rasp rootfs somewhere and set this path as the sysroot below
# I use NFS personally: sudo mount qpii.local:/ /mnt/pi
+# Options
+
+_build_web_engine=false
+
# comment this turkey out in any circumstance when you need to regenate .SRCINFO
#echo "Set your sysroot prior to build" && exit 1
_sysroot=/mnt/pi
@@ -45,7 +49,8 @@ options=('!strip')
install=qpi.install
_device_configure_flags=""
-if [[ ${_piver} = "1" ]]; then
+
+if $_build_web_engine && [[ ${_piver} = "1" ]]; then
_device_configure_flags="-skip qtwebengine"
fi