summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Basaglia2021-05-07 14:55:06 +0000
committerMattia Basaglia2021-05-07 14:55:06 +0000
commit469ce8a197ab9291f31e16152802ca6820ad37ad (patch)
treec72d9ddccc4aa8ca3d35e0b6fe4145dbf33836af
parent6a38059a965dfdab1841b5d8c9b38657088fc1ac (diff)
downloadaur-qt5-color-widgets.tar.gz
Update repo and build scripts
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 32 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c97d153aee4..52db23a92e13 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,25 @@
pkgbase = qt5-color-widgets
pkgdesc = A user-friendly color dialog and several color-related widgets for Qt
- pkgver = 2021.01.01
+ pkgver = 2.2.0
pkgrel = 1
- url = https://github.com/The-Repo-Club/qt5-color-widgets
- arch = any
+ url = https://gitlab.com/mattbas/Qt-Color-Widgets
+ arch = x86_64
+ arch = i686
+ arch = armv7h
+ arch = aarch64
groups = therepoclub
license = LGPL3
makedepends = git
makedepends = cmake
+ makedepends = qt5-tools
depends = qt5-base
optdepends = qt5-tools: for QtDesigner integration
optdepends = qtcreator: for QtCreator integration
provides = qt-color-widgets-common
conflicts = qt-color-widgets-common
replaces = qt5-color-picker
- source = qt5-color-widgets-2021.01.01.tar.gz::https://github.com/The-Repo-Club/qt5-color-widgets/archive/2021.01.01.tar.gz
- sha256sums = 1b6d34bede07885ea068ef9041d2158930b64c15f6d52af42aa0165182fe509c
+ source = qt5-color-widgets::git+https://gitlab.com/mattbas/Qt-Color-Widgets/#branch=master
+ sha256sums = SKIP
pkgname = qt5-color-widgets
diff --git a/PKGBUILD b/PKGBUILD
index d8c5a9209f16..5c9781ee75e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,47 @@
-# Maintainer: The-Repo-Club <The-Repo-Club@github.com>
+# Maintainer: Mattia Basaglia <mattia.basaglia@gmail.com>
# Contributor: The-Repo-Club <The-Repo-Club@github.com>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
# Contributor: Mattia Basaglia <mattia.basaglia@gmail.com>
pkgname=qt5-color-widgets
-pkgver=2021.01.01
+pkgver=2.2.0
pkgrel=1
pkgdesc='A user-friendly color dialog and several color-related widgets for Qt'
-arch=('any')
+arch=('x86_64' 'i686' 'armv7h' 'aarch64')
groups=('therepoclub')
-url="https://github.com/The-Repo-Club/$pkgname"
+url="https://gitlab.com/mattbas/Qt-Color-Widgets"
license=('LGPL3')
depends=('qt5-base')
optdepends=('qt5-tools: for QtDesigner integration'
'qtcreator: for QtCreator integration')
-makedepends=('git' 'cmake')
+makedepends=('git' 'cmake' 'qt5-tools')
provides=('qt-color-widgets-common')
conflicts=('qt-color-widgets-common')
replaces=('qt5-color-picker')
-source=("${pkgname}-$pkgver.tar.gz::${url}/archive/$pkgver.tar.gz")
-sha256sums=('1b6d34bede07885ea068ef9041d2158930b64c15f6d52af42aa0165182fe509c')
+source=(
+ "$pkgname::git+https://gitlab.com/mattbas/Qt-Color-Widgets/#branch=master"
+)
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$pkgname/"
+
+ git submodule update --init --recursive
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- mkdir build
+ cd "$srcdir/$pkgname"
+ mkdir -p build
cd build
- cmake ..
- make QtColorWidgetsPlugin
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make QtColorWidgetsPlugin -j4
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -d "${pkgdir}/usr/include/${pkgname}"
+ cd "$srcdir/$pkgname/build"
+ make install DESTDIR=$pkgdir >/dev/null
mkdir -p "$pkgdir/usr/lib/qt/plugins/designer"
- install -Dvm644 "build/color_widgets_designer_plugin/libQtColorWidgetsPlugin-Qt52.so" "${pkgdir}/usr/lib/qt/plugins/designer/"
- find 'src' -type f -iname '*.hpp' -exec install -Dvm644 {} "${pkgdir}/usr/include/${pkgname}/" \;
- find 'include' -maxdepth 1 -type f -exec install -Dvm644 {} "${pkgdir}/usr/include/${pkgname}/" \;
+ install -Dvm644 "color_widgets_designer_plugin/libQtColorWidgetsPlugin-Qt52.so" "${pkgdir}/usr/lib/qt/plugins/designer/"
}