aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis2015-10-18 18:17:33 +0300
committerDāvis2015-10-18 18:17:33 +0300
commitbf48fb578e1638fa1173140a7f738e3afbe5c6ac (patch)
tree7647128048a88bae8314b5130eb4f1b15028d75d
downloadaur-qt5-sensors-git.tar.gz
Release qt5-sensors-git
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--README.md1
-rw-r--r--UNLICENSE24
5 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9639205828a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qt5-sensors-git
+ pkgdesc = Provides access to sensor hardware and motion gesture recognition
+ pkgver = v5.6.0.alpha1.r14.g5efb5da
+ pkgrel = 1
+ url = https://code.qt.io/cgit/qt/qtsensors.git
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ license = LGPL
+ makedepends = git
+ depends = qt5-declarative-git
+ provides = qt5-sensors
+ conflicts = qt5-sensors
+ source = qt5-sensors::git+https://code.qt.io/qt/qtsensors.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-sensors-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..435e58bff797
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.tar*
+/qt5-sensors/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..70d70e181a96
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Dāvis Mosāns <davispuh at gmail dot com>
+
+_pkgname=qt5-sensors
+pkgname=$_pkgname-git
+pkgver=v5.6.0.alpha1.r14.g5efb5da
+pkgrel=1
+pkgdesc='Provides access to sensor hardware and motion gesture recognition'
+arch=('i686' 'x86_64')
+url='https://code.qt.io/cgit/qt/qtsensors.git'
+license=('GPL3' 'LGPL')
+depends=('qt5-declarative-git')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname::git+https://code.qt.io/qt/qtsensors.git#branch=dev")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$srcdir"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/build"
+
+ qmake "../$_pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ install -D -m644 $srcdir/$_pkgname/LGPL_EXCEPTION.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LGPL_EXCEPTION.txt
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..547c9c8f0560
--- /dev/null
+++ b/README.md
@@ -0,0 +1 @@
+# qt5-sensors-git
diff --git a/UNLICENSE b/UNLICENSE
new file mode 100644
index 000000000000..68a49daad8ff
--- /dev/null
+++ b/UNLICENSE
@@ -0,0 +1,24 @@
+This is free and unencumbered software released into the public domain.
+
+Anyone is free to copy, modify, publish, use, compile, sell, or
+distribute this software, either in source code form or as a compiled
+binary, for any purpose, commercial or non-commercial, and by any
+means.
+
+In jurisdictions that recognize copyright laws, the author or authors
+of this software dedicate any and all copyright interest in the
+software to the public domain. We make this dedication for the benefit
+of the public at large and to the detriment of our heirs and
+successors. We intend this dedication to be an overt act of
+relinquishment in perpetuity of all present and future rights to this
+software under copyright law.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+IN NO EVENT SHALL THE AUTHORS BE LIABLE FOR ANY CLAIM, DAMAGES OR
+OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+OTHER DEALINGS IN THE SOFTWARE.
+
+For more information, please refer to <http://unlicense.org/>