summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormickybart2021-09-13 22:33:52 -0400
committermickybart2021-09-13 22:33:52 -0400
commit7374ce5aaf4c14f6b82d73d9b3edeaf4bd034e1a (patch)
tree2eb305fe133c4c668d192ea0c625e2987f84f7db
parent004a0103159192394f2205ee5d5db2ae70634435 (diff)
downloadaur-qt5-wasm.tar.gz
gcc 11 + emsdk 2.0.29 + fix errno13
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD14
-rw-r--r--qtbase-5.15.2-gcc11.patch37
-rw-r--r--qtwasm_env.sh16
4 files changed, 65 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f99941b611b9..6c319746fae2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-wasm
pkgdesc = A cross-platform application and UI framework for WebAssembly (No multithreading)
pkgver = 5.15.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.qt.io
install = qt5-wasm.install
arch = x86_64
@@ -14,11 +14,12 @@ pkgbase = qt5-wasm
depends = python
options = !strip
source = https://download.qt.io/official_releases/qt/5.15/5.15.2/single/qt-everywhere-src-5.15.2.tar.xz
- source = git+https://github.com/emscripten-core/emsdk.git#tag=2.0.15
+ source = git+https://github.com/emscripten-core/emsdk.git#tag=2.0.29
source = qtwasm_env.sh
+ source = qtbase-5.15.2-gcc11.patch
sha256sums = 3a530d1b243b5dec00bc54937455471aaa3e56849d2593edb8ded07228202240
sha256sums = SKIP
- sha256sums = d5e93f991453f1b9ff9ba6f053520ae0610f32d6f0fa0772f6587f10f3dfe023
+ sha256sums = c124915abf2de106429de9a6bb8907961a662808331933b448b048e5cd215f32
+ sha256sums = a8f2650fba0ba63b6ed7e37ca3ac857314808fa83fc035f343f2cc764c4a8567
pkgname = qt5-wasm
-
diff --git a/PKGBUILD b/PKGBUILD
index f2994a5913cb..089bed75072b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@ pkgname='qt5-wasm'
_qtver=5.15.2
_emsdkver=1.39.8
+_emsdk=2.0.29
_qt="qt-everywhere-src-${_qtver}"
_modules="qtbase qtdeclarative qtquickcontrols2 qtwebsockets qtsvg"
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=('x86_64')
url='https://www.qt.io'
license=('GPL3' 'LGPL3' 'FDL' 'custom')
@@ -21,18 +22,21 @@ conflicts=()
groups=('qt-wasm' 'qt5-wasm')
install=$pkgname.install
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/single/${_qt}.tar.xz"
- 'git+https://github.com/emscripten-core/emsdk.git#tag=2.0.15'
- 'qtwasm_env.sh')
+ "git+https://github.com/emscripten-core/emsdk.git#tag=${_emsdk}"
+ 'qtwasm_env.sh'
+ "qtbase-${_qtver}-gcc11.patch")
sha256sums=('3a530d1b243b5dec00bc54937455471aaa3e56849d2593edb8ded07228202240'
'SKIP'
- 'd5e93f991453f1b9ff9ba6f053520ae0610f32d6f0fa0772f6587f10f3dfe023')
+ 'c124915abf2de106429de9a6bb8907961a662808331933b448b048e5cd215f32'
+ 'a8f2650fba0ba63b6ed7e37ca3ac857314808fa83fc035f343f2cc764c4a8567')
options=('!strip')
_opt=/opt/qt5-wasm
prepare() {
# qt
- cd ${srcdir}/${_qt}
+ cd ${srcdir}/${_qt}/qtbase
+ patch -p1 < ${srcdir}/qtbase-${_qtver}-gcc11.patch
# emsdk
cd ${srcdir}/emsdk
diff --git a/qtbase-5.15.2-gcc11.patch b/qtbase-5.15.2-gcc11.patch
new file mode 100644
index 000000000000..36327da6c944
--- /dev/null
+++ b/qtbase-5.15.2-gcc11.patch
@@ -0,0 +1,37 @@
+Description: include <limits> to fix some GCC 11 build issues
+Origin: upstream, commits:
+ https://code.qt.io/cgit/qt/qtbase.git/commit/?id=813a928c7c3cf986
+ https://code.qt.io/cgit/qt/qtbase.git/commit/?id=9c56d4da2ff631a8
+Last-Update: 2021-01-26
+
+--- a/src/corelib/global/qendian.h
++++ b/src/corelib/global/qendian.h
+@@ -44,6 +44,8 @@
+ #include <QtCore/qfloat16.h>
+ #include <QtCore/qglobal.h>
+
++#include <limits>
++
+ // include stdlib.h and hope that it defines __GLIBC__ for glibc-based systems
+ #include <stdlib.h>
+ #include <string.h>
+--- a/src/corelib/global/qfloat16.h
++++ b/src/corelib/global/qfloat16.h
+@@ -43,6 +43,7 @@
+
+ #include <QtCore/qglobal.h>
+ #include <QtCore/qmetatype.h>
++#include <limits>
+ #include <string.h>
+
+ #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
+--- a/src/corelib/text/qbytearraymatcher.h
++++ b/src/corelib/text/qbytearraymatcher.h
+@@ -42,6 +42,8 @@
+
+ #include <QtCore/qbytearray.h>
+
++#include <limits>
++
+ QT_BEGIN_NAMESPACE
+
diff --git a/qtwasm_env.sh b/qtwasm_env.sh
index 9521af45fb23..8b5a49e42ec4 100644
--- a/qtwasm_env.sh
+++ b/qtwasm_env.sh
@@ -1,3 +1,15 @@
-/opt/qt5-wasm/emsdk/emsdk activate EMSDKVER
+#/opt/qt5-wasm/emsdk/emsdk activate EMSDKVER
+
+# load emsdk environment
+# EM_CACHE issue: https://github.com/emscripten-core/emsdk/issues/535
+EM_CACHE_PATH=~/.cache/qt5-wasm
+export EM_CACHE=$EM_CACHE_PATH
source /opt/qt5-wasm/emsdk/emsdk_env.sh
-export PATH=/opt/qt5-wasm/bin:$PATH
+export EM_CACHE=$EM_CACHE_PATH
+echo "EM_CACHE (override) = $EM_CACHE"
+
+# Export Qt5 WebAssembly bin Path
+echo $PATH | grep -w "/opt/qt5-wasm/bin" > /dev/null
+if [ $? -ne 0 ]; then
+ export PATH=/opt/qt5-wasm/bin:$PATH
+fi