summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYoann Laissus2015-08-02 13:09:40 +0200
committerYoann Laissus2015-08-02 13:13:59 +0200
commit551c00e7bca50912eba04fac66f71f391d82558b (patch)
treed4a01e1e6fdc675df4048df1dfd629450ce51bd2
downloadaur-qtcreator-freebox-plugin-git.tar.gz
Initial import of qtcreator-freebox-plugin-git.
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore13
-rw-r--r--PKGBUILD34
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e7ea72ace242
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = qtcreator-freebox-plugin-git
+ pkgdesc = QtCreator Freebox Plugin
+ pkgver = r16.75afac6
+ pkgrel = 1
+ url = https://github.com/fbx/freebox-qtcreator-plugin
+ arch = i686
+ arch = x86_64
+ groups = qt
+ groups = qt5
+ license = LGPL
+ makedepends = git
+ makedepends = qtcreator-src
+ depends = qtcreator
+ provides = qtcreator-freebox-plugin
+ conflicts = qtcreator-freebox-plugin
+ source = qtcreator-freebox-plugin-git::git://github.com/fbx/freebox-qtcreator-plugin.git
+ md5sums = SKIP
+
+pkgname = qtcreator-freebox-plugin-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..058b83f604ec
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,13 @@
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!*.install
+!ChangeLog
+!.SRCINFO
+
+# Patches
+!*.diff
+!*.patch
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16e77cfa8656
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Yoann Laissus <yoann.laissus@gmail.com>
+
+_pkgname=qtcreator-freebox-plugin
+pkgname=${_pkgname}-git
+pkgver=r16.75afac6
+pkgrel=1
+pkgdesc="QtCreator Freebox Plugin"
+groups=('qt' 'qt5')
+arch=('i686' 'x86_64')
+url='https://github.com/fbx/freebox-qtcreator-plugin'
+license=('LGPL')
+depends=('qtcreator')
+makedepends=('git' 'qtcreator-src')
+# Prepare this package if ever there is a release of this tool
+provides=('qtcreator-freebox-plugin')
+conflicts=('qtcreator-freebox-plugin')
+source=("$pkgname::git://github.com/fbx/freebox-qtcreator-plugin.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ QTC_SOURCE=/usr/src/qtcreator QTC_BUILD=build/usr qmake LIBS+="-L/usr/lib/qtcreator -L/usr/lib/qtcreator/plugins"
+ make
+}
+
+package() {
+ cd $pkgname
+ cp -r build/* ${pkgdir}
+}