summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Mangold2017-06-01 11:36:49 +0200
committerOliver Mangold2017-06-01 11:36:49 +0200
commit186f79eab8860594d3f9dc325a55551a19b2d98f (patch)
tree2ba275d43c6238b25cf7691d4118b723a070f956
downloadaur-qtdomterm.tar.gz
initial packaging
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--qtdomterm.desktop10
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10b6adc89aee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Jun 1 09:35:58 UTC 2017
+pkgbase = qtdomterm
+ pkgdesc = Terminal emulator capable of display html and images from command output
+ pkgver = 0.72
+ pkgrel = 1
+ url = ttps://github.com/PerBothner/DomTerm
+ arch = any
+ license = BSD
+ depends = json-c
+ depends = qt5-webengine
+ depends = qt5-webchannel
+ source = git+https://github.com/PerBothner/DomTerm.git#commit=b53ffa6410f381da4067715b1dc11a2b58e35985
+ source = qtdomterm.desktop
+ md5sums = SKIP
+ md5sums = d35f7bd80b0c6cda9da182a019914d9a
+
+pkgname = qtdomterm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26bb932b4d2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Oliver Mangold <o dot mangold at gmail dot com>
+
+pkgname=qtdomterm
+pkgver=0.72
+pkgrel=1
+pkgdesc="Terminal emulator capable of display html and images from command output"
+arch=('any')
+url=ttps://github.com/PerBothner/DomTerm
+license=('BSD')
+groups=()
+depends=(json-c qt5-webengine qt5-webchannel)
+source=('git+https://github.com/PerBothner/DomTerm.git#commit=b53ffa6410f381da4067715b1dc11a2b58e35985' qtdomterm.desktop)
+md5sums=(SKIP 'd35f7bd80b0c6cda9da182a019914d9a')
+
+build() {
+ cd "$srcdir"/DomTerm
+ autoreconf
+ ./configure --disable-pty --with-qtwebengine --without-java --without-libwebsockets --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir"/DomTerm
+ make install DESTDIR="$pkgdir"
+ install -m 755 "$srcdir"/DomTerm/bin/{h,img,svg}cat "$pkgdir"/usr/bin
+ install -m 755 -d "$pkgdir"/usr/share/applications/
+ install -m 644 "$srcdir"/qtdomterm.desktop "$pkgdir"/usr/share/applications/qtdomterm.desktop
+}
diff --git a/qtdomterm.desktop b/qtdomterm.desktop
new file mode 100644
index 000000000000..7bcefb54d34c
--- /dev/null
+++ b/qtdomterm.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=qtdomterm
+GenericName=Terminal
+Exec=qtdomterm
+Terminal=false
+Type=Application
+Encoding=UTF-8
+Categories=Qt;System;TerminalEmulator;
+Keywords=shell;prompt;command;commandline;cmd;
+Icon=utilities-terminal