summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2021-06-06 18:08:59 +0200
committerhaawda2021-06-06 18:08:59 +0200
commit8a3322efea6dd1473cec4f36a94c0b7b36f8f326 (patch)
treeb1f56213f674801c3288b433ae5fa3e216c9076b
parent3549fce2943e6badf7334fbf5f4aed6e88006c6e (diff)
downloadaur-qtfm.tar.gz
Update, patch no longer needed
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD14
-rw-r--r--qt-5.15+gentoo.patch22
3 files changed, 8 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd7d608a5247..0669523dff49 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtfm
pkgdesc = A lightweight file manager
- pkgver = 6.2.0
- pkgrel = 2
+ pkgver = 6.2.1
+ pkgrel = 1
url = https://github.com/rodlie/qtfm/releases
arch = i686
arch = x86_64
@@ -9,10 +9,7 @@ pkgbase = qtfm
depends = qt5-base
depends = desktop-file-utils
depends = hicolor-icon-theme
- source = qtfm-6.2.0.tar.gz::https://github.com/rodlie/qtfm/archive/6.2.0.tar.gz
- source = qt-5.15+gentoo.patch
- sha256sums = 58c6af502b606e63f96e8aec96b65ca9125be18ecdd5e4680ccaf50e9c40b064
- sha256sums = 143a664ccd9b677924f6168d7d358201b8693a03f3a0c76efe348f7b39489b99
+ source = qtfm-6.2.1.tar.gz::https://github.com/rodlie/qtfm/archive/6.2.1.tar.gz
+ sha256sums = b9c707443e20644f6e5f0393ce5158843724ac08f92cf8d7ea8e1109957b5c00
pkgname = qtfm
-
diff --git a/PKGBUILD b/PKGBUILD
index d28505f681a6..77d452d25420 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,15 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=qtfm
-pkgver=6.2.0
-pkgrel=2
+pkgver=6.2.1
+pkgrel=1
pkgdesc="A lightweight file manager"
arch=('i686' 'x86_64')
url="https://github.com/rodlie/qtfm/releases"
license=('GPL')
depends=('qt5-base' 'desktop-file-utils' 'hicolor-icon-theme')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/rodlie/$pkgname/archive/$pkgver.tar.gz" qt-5.15+gentoo.patch)
-sha256sums=('58c6af502b606e63f96e8aec96b65ca9125be18ecdd5e4680ccaf50e9c40b064'
- '34271a58f32eeed01ab2db408505e8a1cef20f4a60a372ba78c5607b404eb010')
-
-prepare() {
- cd $pkgname-${pkgver//_/-}
- patch -Np1 < "$srcdir"/qt-5.15+gentoo.patch
-}
+source=("$pkgname-$pkgver.tar.gz::https://github.com/rodlie/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('b9c707443e20644f6e5f0393ce5158843724ac08f92cf8d7ea8e1109957b5c00')
build() {
cd $pkgname-${pkgver//_/-}
diff --git a/qt-5.15+gentoo.patch b/qt-5.15+gentoo.patch
deleted file mode 100644
index 5c286c792d75..000000000000
--- a/qt-5.15+gentoo.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur qtfm-6.2.0.orig/libfm/iconlist.cpp qtfm-6.2.0.new/libfm/iconlist.cpp
---- qtfm-6.2.0.orig/libfm/iconlist.cpp 2019-06-04 07:47:00.000000000 +0200
-+++ qtfm-6.2.0.new/libfm/iconlist.cpp 2020-08-02 17:47:04.899432194 +0200
-@@ -1,5 +1,7 @@
- #include "iconlist.h"
-
-+#include <QPainterPath>
-+
- QSize IconListDelegate::sizeHint(const QStyleOptionViewItem &option,
- const QModelIndex &index) const
- {
-diff -Naur qtfm-6.2.0.orig/libfm/iconview.cpp qtfm-6.2.0.new/libfm/iconview.cpp
---- qtfm-6.2.0.orig/libfm/iconview.cpp 2019-06-04 07:47:00.000000000 +0200
-+++ qtfm-6.2.0.new/libfm/iconview.cpp 2020-08-02 17:46:53.629482772 +0200
-@@ -1,5 +1,7 @@
- #include "iconview.h"
-
-+#include <QPainterPath>
-+
- bool IconViewDelegate::eventFilter(QObject *object,
- QEvent *event)
- {