summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartchus2024-02-28 15:04:13 +0100
committerMartchus2024-02-28 15:04:13 +0100
commitcf75d4e9088d7f839b02a85bf4f03bc0a6c3f8da (patch)
treeb85334cec50a2c13aff2980e6a28fd9e132c0400
parent84f0181661057de21e9bfdc5ae2e53df84cea9a8 (diff)
downloadaur-qtforkawesome-git.tar.gz
Use Qt 6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 737686122218..d3fc3ea67cde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qtforkawesome-git
pkgdesc = Library that bundles ForkAwesome for use within Qt applications
pkgver = 46.1c92ea5
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Martchus/qtforkawesome
arch = i686
arch = x86_64
@@ -14,9 +14,10 @@ pkgbase = qtforkawesome-git
makedepends = ninja
makedepends = perl-yaml-libyaml
makedepends = qtutilities-git
- makedepends = qt5-declarative
- depends = qt5-base
- optdepends = qt5-declarative: Qt Quick integration
+ makedepends = qt6-declarative
+ makedepends = clang
+ depends = qt6-base
+ optdepends = qt6-declarative: Qt Quick integration
optdepends = qtforkawesome-doc: API documentation
provides = libqtforkawesome-git.so
provides = libqtquickforkawesome-git.so
diff --git a/PKGBUILD b/PKGBUILD
index 07964983030a..88689d4ec924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,16 +9,16 @@ _reponame_forkawesome=Fork-Awesome-$_pkgver_forkawesome
pkgname=qtforkawesome-git
_name=${pkgname%-git}
pkgver=46.1c92ea5
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
pkgdesc='Library that bundles ForkAwesome for use within Qt applications'
license=('GPL')
-depends=('qt5-base')
+depends=('qt6-base')
optdepends=(
- 'qt5-declarative: Qt Quick integration'
+ 'qt6-declarative: Qt Quick integration'
"$_name-doc: API documentation"
)
-makedepends=('cmake' 'git' 'ninja' 'perl-yaml-libyaml' 'qtutilities-git' 'qt5-declarative')
+makedepends=('cmake' 'git' 'ninja' 'perl-yaml-libyaml' 'qtutilities-git' 'qt6-declarative' 'clang')
provides=(libqtforkawesome-git.so libqtquickforkawesome-git.so)
url="https://github.com/Martchus/${_reponame}"
source=("${_reponame}::${MARTCHUS_GIT_URL_PREFIX:-git+https://github.com/Martchus}/${_reponame}.git"
@@ -40,6 +40,8 @@ build() {
-DCONFIGURATION_NAME:STRING='git' \
-DCONFIGURATION_PACKAGE_SUFFIX:STRING='-git' \
-DCONFIGURATION_TARGET_SUFFIX:STRING='git' \
+ -DQT_PACKAGE_PREFIX:STRING='Qt6' \
+ -DKF_PACKAGE_PREFIX:STRING='KF6' \
-DBUILD_SHARED_LIBS:BOOL=ON \
-DBUILTIN_TRANSLATIONS:BOOL=ON \
-DFORK_AWESOME_FONT_FILE="$srcdir/${_reponame_forkawesome}/fonts/forkawesome-webfont.woff2" \